Closed Bug 1235939 Opened 6 years ago Closed 6 years ago

Intermittent text_keyboard_test.js | Text keyboard input tests <textarea> tests tap space bar and then wait for a while before tapping again

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: KWierso, Assigned: ralin)

Details

(Keywords: intermittent-failure, Whiteboard: [MJS])

It looks like autocorrect is failing in CI sometimes. FWIW, I've also seen this happen on device sometimes.

05:48:20     INFO -  TEST-UNEXPECTED-FAIL | apps/keyboard/test/marionette/text_keyboard_test.js | Text keyboard input tests <textarea> tests Double tapping space bar
05:48:20     INFO -  AssertionError: 'As. ' == 'Aa. '
05:48:20     INFO -      at Context.<anonymous> (apps/keyboard/test/marionette/text_keyboard_test.js:129:14)
05:48:20     INFO -      at Test.MarionetteTest.run (node_modules/marionette-js-runner/lib/ui.js:25:31)

https://treeherder.mozilla.org/logviewer.html#?job_id=3650850&repo=b2g-inbound

Tim, can you find someone to take a look here?
Flags: needinfo?(timdream)
Whiteboard: [MJS]
It looks like we do not wait for auto correction of "Aa" to "As" to appear before tapping the two spaces, and our machines have now start to be fast enough...:

https://github.com/mozilla-b2g/gaia/commit/702773bee0b70e479ccebe5e061f571e977bc376#diff-ff8ba3b17002b762c8322936a9908b7dR121

Ray, could you add that and see if my assumption is correct? Thank you very much!
Flags: needinfo?(timdream) → needinfo?(ralin)
No problem, I'll take care of it.
Flags: needinfo?(ralin)
I tried to make my Z3C laggy to reproduce this issue. Just like Tim said, we need to wait a short time interval to display suggestion and let the first suggestion to be the auto correction candidate. If two tapping are happened within this interval, our output could fall to "Aa." instead of "As."

Adding waiting time between two space should help.
Assignee: nobody → ralin
This has been happening a lot the last few days [1], so I'm going to disable the test while we have a fix incoming.
be done in: bug 1233533

https://github.com/mozilla-b2g/gaia/commit/6cc114b84b7f392010ab5f31460e13a0b4175666
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.