Set up tor onion service access to our web properties.

RESOLVED INCOMPLETE

Status

Infrastructure & Operations
WebOps: Other
--
enhancement
RESOLVED INCOMPLETE
2 years ago
2 years ago

People

(Reporter: huseby, Assigned: w0ts0n)

Tracking

(Blocks: 1 bug)

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/3135])

(Reporter)

Description

2 years ago
Let's set up tor onion service access to our web properties:

mozilla.org
firefox.org
bugzilla.mozilla.org
addons.mozilla.org
developer.mozilla.org
wiki.mozilla.org
intranet.mozilla.org
mana.mozilla.org

Updated

2 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/2382]
(Assignee)

Comment 1

2 years ago
Tentatively taken this bug to discuss in our next webops meeting.
:)
Assignee: server-ops-webops → rwatson

Comment 2

2 years ago
I'm intrigued by this project, but have no idea what sort of time investment is needed.

I'll watch the talk linked in the parent bug.
Given our resource and time constraints - we aren't going to be able to get to this anytime soon.

We'll keep an eye on this and re-open as and when we can get this going. Marking INCOMPLETE.
Severity: normal → enhancement
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

2 years ago
The compelling reason to deploy and maintain .onion access to our web properties has to with how the Tor network is organized.  Exit nodes in the Tor network are the primary bottleneck in terms of bandwidth.  If we provide .onion access, then accessing our web properties anonymously over the Tor network will not consume any of the bandwidth of the exit nodes.
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

Updated

2 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/2382] → [kanban:https://webops.kanbanize.com/ctrl_board/2/3135]
(Assignee)

Comment 5

2 years ago
We understand the reason, the issue isn't reason, it's resource and time constraints. Webops won't be able to get to this any time soon, so we are closing bugs as incomplete (so we can come back to them later, when we find time) vs leaving it open and not working on it.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → INCOMPLETE

Comment 6

2 years ago
Dave, maybe you can help clarify exactly what needs to happen. For example, when you talk about bugzilla.mozilla.org -- there are many links generated from that web app back to itself as well as links that go to other services (like mozreview).  What's the expectation here? Do you imagine we have those web apps generate onion links instead of https?  (that part's not clear to me).
You need to log in before you can comment on or make changes to this bug.