Closed Bug 1236004 Opened 7 years ago Closed 6 years ago

The "Allow debug connection" confirmation dialog doesn't support keyboard.

Categories

(Firefox OS Graveyard :: Gaia::TV::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

RESOLVED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: rexboy, Assigned: rexboy)

References

Details

(Whiteboard: [ft:conndevices])

Attachments

(2 files)

STR:
1. Make a build without DEVICE_DEBUG=1.
2. launch the build
3. Connect it through WebIDE
4. Wait for "Allow debug connection" confirmation dialog.

expected:
- confirmation dialog can be manipulated by keyboard.

actual:
- confirmation dialog only supports mouse click.
Comment on attachment 8704508 [details] [review]
[gaia] rexboy7:1236004-system-modal-dialog > mozilla-b2g:master

I just glued SmartModalDialog and SmartInputDialog into ModalDialog class. So it can be compatible with 'alert', 'confirm', and 'prompt' dialogs. For now there are no use cases in smart-system for 'prompt' though.

So we still got 'selectone' dialog that's still not compatible with TV, but it's used only in AppChrome for bookmarking, and I'm not even sure if we have that feature on TV. So I leaved it unchanged.

Luke may you help review this bug? I think it's not very high priority so you may do it when you are idle. Thank you!
Attachment #8704508 - Flags: review?(lchang)
Assignee: nobody → rexboy
Status: NEW → ASSIGNED
Comment on attachment 8704508 [details] [review]
[gaia] rexboy7:1236004-system-modal-dialog > mozilla-b2g:master

Everything looks good.
Attachment #8704508 - Flags: review?(lchang) → review+
https://github.com/mozilla-b2g/gaia/commit/c2672724a0cfd281070989e6cadf34960346ed7d

Forgot to merge it :-/
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8704508 [details] [review]
[gaia] rexboy7:1236004-system-modal-dialog > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1236004
[User impact] if declined: Caused bug 1257737
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: No


This patch haven't uplift to v2.5 branch and caused bug 1257737.
Attachment #8704508 - Flags: approval-gaia-v2.5?(jocheng)
Duplicate of this bug: 1257737
Duplicate of this bug: 1257740
Comment on attachment 8704508 [details] [review]
[gaia] rexboy7:1236004-system-modal-dialog > mozilla-b2g:master

Approve for TV 2.5
Attachment #8704508 - Flags: approval-gaia-v2.5?(jocheng) → approval-gaia-v2.5+
Whiteboard: [ft:conndevices]
blocking-b2g: --- → 2.5+
You need to log in before you can comment on or make changes to this bug.