Kerio Connect Client stops working with "too much recursion" on Firefox 64-bit for Windows

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: meszaros.gyula, Unassigned)

Tracking

({regression})

36 Branch
x86_64
Windows 10
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151223140742

Steps to reproduce:

- Opened Kerio Connect Client from Firefox (https://servername/webmail)
- Tried to log in
(Firefox 43.0.3 x64 HU, Windows 10 Pro 64-bit HU)


Actual results:

Kerio Connect Client crashed with "ErrorMessage: too much recursion"


Expected results:

Kerio Connect Client logs in into Kerio Connect Server
It works flawlessly for years on 32-bit Firefox and all the other browsers, including Edge. Kerio support answered that the problem is in Firefox, according to them.

Updated

3 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Summary: Kerio Connect Client crashes on Firefox 64-bit for Windows → Kerio Connect Client stop works with "too much recursion" on Firefox 64-bit for Windows
(Reporter)

Comment 1

3 years ago
I can create a test account on my mailserver, if it helps, but I did not wish to write the credentials here. Please notify me if from a verifiable official e-mail address where I can send the data to. Or is there any other method to provide sensitive information?
(Reporter)

Comment 2

3 years ago
Here is a similar case on a different platform, the common thing is the 64-bit Firefox:
http://forums.kerio.com/t/30273//

Comment 3

3 years ago
(In reply to Mészáros Gyula from comment #1)
> I can create a test account on my mailserver, if it helps, but I did not
> wish to write the credentials here. Please notify me if from a verifiable
> official e-mail address where I can send the data to. Or is there any other
> method to provide sensitive information?

Yes, it would be nice to send guest account credentials to reproduce the crash. You can right click on my userame to get the email address.
Flags: needinfo?(mgyhardsoft)
(Reporter)

Comment 4

3 years ago
The mail has been sent.
(Reporter)

Updated

3 years ago
Flags: needinfo?(mgyhardsoft)

Updated

3 years ago
Component: Untriaged → JavaScript Engine
Product: Firefox → Core

Comment 5

3 years ago
Indeed, 32b builds work fine, only the 64b version has the bug.
In the past, it worked fine with 64b builds, no error message during the initialization of the webmail loading.

Regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=88adcf8fef83&tochange=d6abb9bf43be
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: 43 Branch → 36 Branch
Any chance to either get credentials, the original source code or a minimal test case reproducing the same issue?

Comment 7

3 years ago
(In reply to Benjamin Bouvier [:bbouvier] from comment #6)
> Any chance to either get credentials, the original source code or a minimal
> test case reproducing the same issue?

Email sent.
64-bit stack frames are likely to be bigger than 32-bit ones, and Windows has tiny stack sizes by default (and larger stackframes due to PGO, too).

Should 64-bit windows builds use a larger default thread stack than 32-bit ones, perhaps (and correspondingly larger JS stack limits), since address space exhaustion is less of an issue there?
Flags: needinfo?(benjamin)
(In reply to Benjamin Bouvier [:bbouvier] from comment #6)
> Any chance to either get credentials, the original source code or a minimal
> test case reproducing the same issue?

Maybe you can post them in a private comment? :)

(In reply to Boris Zbarsky [:bz] (Vacation until Jan 4) from comment #8)
> 64-bit stack frames are likely to be bigger than 32-bit ones, and Windows
> has tiny stack sizes by default (and larger stackframes due to PGO, too).

Yes we keep seeing these issues on Win64 :(
(Reporter)

Comment 11

3 years ago
(In reply to Jan de Mooij [:jandem] from comment #9)
> (In reply to Benjamin Bouvier [:bbouvier] from comment #6)
> > Any chance to either get credentials, the original source code or a minimal
> > test case reproducing the same issue?
> 
> Maybe you can post them in a private comment? :)


Hi,

How to send private comment? By the time I figure it out, I have sent the credentials to a couple of Benjamins, namely: benjamin@smedbergs.us and bbouvier@mozilla.com. HTH, and also that the credentials will be in good hands. Anyone else needs them? There is a year starting action just now, just for you!!! :-)
(In reply to Mészáros Gyula from comment #11)
> Hi,
> 
> How to send private comment?

Thank you. I've posted them in a private comment above. As it's private, only people with specific permissions can see it (and post this kind of comments).
(Reporter)

Comment 13

3 years ago
(In reply to Benjamin Bouvier [:bbouvier] from comment #12)
> (In reply to Mészáros Gyula from comment #11)
> > Hi,
> > 
> > How to send private comment?
> 
> Thank you. I've posted them in a private comment above. As it's private,
> only people with specific permissions can see it (and post this kind of
> comments).

Thanks! Yes, I see that I cannot see Comment #10...
(Reporter)

Comment 14

3 years ago
I tried it on openSUSE 42.1 x86_64 and it works well with Firefox 43.0.3-9.2-x86_64. I suppose it is a specific build made by the SuSE people, so it may not be relevant for you, anyway, it is also a piece of information (I hope).

Comment 15

3 years ago
We should make stacks as large as they reasonably need to be, but should avoid making them excessively large. Even with 64-bit we've seen weird VM fragmentation issues. I don't have any data or opinion on the actual size they should be.
Flags: needinfo?(benjamin)
OK.  I think last I checked our thread stacks on windows were something like 1/8 as big as on Linux...
(Reporter)

Comment 17

a year ago
I don't know how and why, but finally the bug became resolved (now Kerio Connect client works well on 64-bit Firefox 55.0.2.
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Summary: Kerio Connect Client stop works with "too much recursion" on Firefox 64-bit for Windows → Kerio Connect Client stops working with "too much recursion" on Firefox 64-bit for Windows
You need to log in before you can comment on or make changes to this bug.