User added search engines are gone when downgrade from Version45

RESOLVED WONTFIX

Status

()

Firefox
Search
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

45 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox45 affected, firefox-esr45 ?)

Details

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]:

Steps to reproduce:
1. Start Aurora45.0a2
2. Add search engine ( https://addons.mozilla.org/en-US/firefox/search/?atype=4 )
3. Exit browser
4. Start Firefox38ESR


Actual Results:
User added search engines are gone

Expected Results:
User added search engines should be kept
Not writing user-installed search engines in the old format is an intended change. I know it can cause minor inconvenience for users moving back and forth between 2 releases, but I don't think it's worth attempting to fix (it's not the end of the world to have to install an engine again in this edge case).

While working on bug 1203167, I ensured that if someone uses Fx44, then upgrades to 45, and then downgrades to 44, all the settings that had been set in Firefox 44 are still available in Firefox 44 (and they are also migrated to Firefox 45 of course). However, if someone changes search settings in Firefox 45, Firefox 44 won't be able to see them.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.