Status

Firefox OS
Gaia::Feedback
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: shahbaz17, Unassigned)

Tracking

({foxfood, qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bzlite])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

When I open any geolocation app it is not showing me my exact location. Tried Google maps, Find me Google App also visited https://developer.mozilla.org/en-US/docs/Web/API/Geolocation/Using_geolocation

Gelocation is enabled in Settings also when any app asks for Gelocation I chose share my location
(Reporter)

Comment 1

3 years ago
Created attachment 8703265 [details]
2016-01-01-17-11-12.png
(Reporter)

Comment 2

3 years ago
Device : Sony xperia z3c

Comment 3

3 years ago
I cannot reproduce this with my Flame running OTA 20160103150204
Seems like a possible duplicate. 

QAnalysts - Can you please find the duplicate and mark it. Thanks
Keywords: qawanted
Unable to reproduce on Aries using: 

Build ID               20160105105910
Gaia Revision          78b2bc4cad3fcf83cbbbe4aeb77079cf956972cf
Gaia Date              2016-01-04 16:24:13
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/29258f59e5456a1a518ccce6b473b50c1173477e
Gecko Version          46.0a1
Device Name            aries


I tried an earlier build as well, and that site worked fine for me.
Reporter: Is this still an issue?
Flags: needinfo?(shahbazalam17feb)
(Reporter)

Comment 7

3 years ago
Now it is working. But not showing the exact location. And Geolocation doesn't work on WiFi network.
Flags: needinfo?(shahbazalam17feb) → needinfo?(mozillamarcia.knous)
Please read : https://wiki.mozilla.org/B2G/QA/Geolocation

Geolocation is done via MLS, AGPS, and GPS.

MLS is only as good as the mapping of the area.

AGPS needs to be configured with a server since the only way we currently do it is via AGPS server AFAIK: ( https://bugzilla.mozilla.org/show_bug.cgi?id=1196646 / https://bugzilla.mozilla.org/show_bug.cgi?id=1177413 / https://bugzilla.mozilla.org/show_bug.cgi?id=1176013 ).

GPS takes 15 minutes outdoors to lock on and is based on the chip on the device.

MLS is only as good as our data points on our server.  If you want to improve the reading via wifi, please contribute to MLS : https://location.services.mozilla.com/
Adding ni back on the reporter to bring Comment 8 to his attention.
Flags: needinfo?(mozillamarcia.knous) → needinfo?(shahbazalam17feb)
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(shahbazalam17feb)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.