Simultaneous across all trees permaorange tv_apps/smart-system/fxa/test/marionette/fxa_screen_flow_test.js | Firefox Accounts Screen Flow Test (UITest app) should walk screen flow for new user

RESOLVED DUPLICATE of bug 1236157

Status

Firefox OS
Gaia::TV
--
blocker
RESOLVED DUPLICATE of bug 1236157
2 years ago
2 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
This starting to happen just after midnight UTC 2016-01-01 makes me think a timebomb in the test, and "at Object.FxA.enterCOPPANew" makes me think it's the result of failing to deal with the unexpected appearance of 2016 as a possible birth year.

Lacking any way to disable the test, I'll be hiding the entire Gij-40 chunk until the test is disabled or fixed.

https://treeherder.mozilla.org/logviewer.html#?job_id=6392585&repo=fx-team

00:43:09     INFO -  TEST-UNEXPECTED-FAIL | tv_apps/smart-system/fxa/test/marionette/fxa_screen_flow_test.js | Firefox Accounts Screen Flow Test (UITest app) should walk screen flow for new user
00:43:09     INFO -  TypeError: Cannot read property 'scriptWith' of null
00:43:09     INFO -      at Object.MarionetteHelper.tapSelectOption (node_modules/marionette-helper/index.js:303:19)
00:43:09     INFO -      at Object.FxA.enterCOPPANew (tv_apps/smart-system/fxa/test/marionette/lib/fxa.js:94:26)
00:43:09     INFO -      at Context.<anonymous> (tv_apps/smart-system/fxa/test/marionette/fxa_screen_flow_test.js:48:9)
00:43:09     INFO -      at Test.MarionetteTest.run (node_modules/marionette-js-runner/lib/ui.js:25:31)
00:43:09     INFO -      at tv_apps/smart-system/fxa/test/marionette/fxa_screen_flow_test.js:34:7
00:43:09     INFO -      at ChildProcess.<anonymous> (tv_apps/smart-system/fxa/test/marionette/lib/server.js:30:9)
00:43:09     INFO -      at handleMessage (internal/child_process.js:686:10)
00:43:09     INFO -      at Pipe.channel.onread (internal/child_process.js:440:11)
00:43:09     INFO -  TEST-END | tv_apps/smart-system/fxa/test/marionette/fxa_screen_flow_test.js | Firefox Accounts Screen Flow Test (UITest app) should walk screen flow for new user took 1377 ms
(Reporter)

Updated

2 years ago
Blocks: 1236146
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1236157
(Reporter)

Updated

2 years ago
No longer blocks: 1236146

Comment 2

2 years ago
29 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 15
* mozilla-inbound: 14

Platform breakdown:
* b2g-linux64: 15
* mulet-linux64: 14

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1236145&startday=2015-12-28&endday=2016-01-03&tree=all
You need to log in before you can comment on or make changes to this bug.