Status

SeaMonkey
General
--
critical
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Gili, Assigned: mkaply)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:0.9.7+) Gecko/20020122
BuildID:    2002012216

When using Mozilla to visit a Java-activated webpage, IBM's JDK 1.3 plugin loads
up. 

30% of the time, bufferCreator (spawned by the plugin) will die, turn Zombie (it
cannot be killed using kill -9) and at the same time it will hang the entire
system and require a reboot.

Reproducible: Sometimes
Steps to Reproduce:
1. Visit any java-activated website for the first time
2.
3.
(Assignee)

Comment 1

16 years ago
What version of Java 1.3 do you have?

This hang is a 100% Java hang unrelated to Mozilla.
(Reporter)

Comment 2

16 years ago
I am running JDK 1.3 build co130-20010925. This has been a major issue for the
past 6 months. Could you *please* forward this to IBM's Java team? I am sure
many of their customers are experiencing this problem.

Also, I have posted various bug reports to ibmpub.java.os2 and comp.os.os2.bugs
newsgroups but they went unanswered. Since this issue is related to Mozilla
(triggered quite often when using Mozilla, not nearly as often during normal
Java application use) I would appreciate you passing this on to them.

Thank you,
Gili Tzabari
(Reporter)

Comment 3

16 years ago
... I used to think all Java apps could potencially trigger the bufferCreator
issue I just mentioned; but I'm beginning to doubt that. 

In total, I remember seeing a single incident where a Java app triggered a
bufferCreator hang; all other cases (over a hundred in total) were triggered by
Mozilla + Java plugin. As such, I am fairly certain that even that first
incident was probably related to Mozilla (it was probably minimized in the
background) and the bug is probably somewhere in the Java plugin for Mozilla;
not in the Java runtime itself. As such, I think this issue is Mozilla-specific,
not Java specific.
(Assignee)

Comment 4

16 years ago
If you rename PMDDEML.DLL in your OS2\DLL directory to PMDDEML.BAK, you won't 
see the hangs.
(Assignee)

Comment 5

16 years ago
We have determined that the hangs are caused by a bug in PMDDEML.

I am going to use this bug to checkin a change to Mozilla that does NOT 
enable DDE by default.

This should cause the hangs to turn into crashes which will make them 
easier to reproduce and debug.
Assignee: asa → mkaply
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: bufferCreator crashes WPS → PMDDEML hang
(Assignee)

Comment 6

16 years ago
Created attachment 77079 [details] [diff] [review]
Make dde not the default - add /dde flag

Comment 7

16 years ago
Comment on attachment 77079 [details] [diff] [review]
Make dde not the default - add /dde flag

r=law

Now nobody can say I didn't help out with the OS/2 port.
Attachment #77079 - Flags: review+
(Assignee)

Comment 8

16 years ago
Comment on attachment 77079 [details] [diff] [review]
Make dde not the default - add /dde flag

Taking the sr=blizzard on this since the file is 100% OS/2
Attachment #77079 - Flags: superreview+

Comment 9

16 years ago
Comment on attachment 77079 [details] [diff] [review]
Make dde not the default - add /dde flag

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #77079 - Flags: approval+
(Assignee)

Comment 10

16 years ago
Fix checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

15 years ago
Verified - we don't default to having DDE on anymore.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.