Hit-testing is broken for photos & links-to-photos in Yelp comments. (They don't get styled on hover, and clicking has no effect)

RESOLVED DUPLICATE of bug 1226904

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1226904
2 years ago
2 years ago

People

(Reporter: Jerod Lycett, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
+++ This bug was initially created as a clone of Bug #1226904 +++

STR:
 1. Visit http://www.yelp.com/biz/j-and-m-hobby-house-san-carlos?start=20

 2. Scroll down to the comment with some photos from "lynn c." (it's the 4th comment shown on the page, right now)

 3. Hover the link below the photos. If you like, try to click it.

EXPECTED RESULTS:
Link & cursor should change on link-hover (as they normally do). Clicking link should be functional.

ACTUAL RESULTS:
Link/cursor do not change on hover. Clicking link has no effect.

This regressed in the last week. m-c regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=48d636f678b0e5162ab868dc9024a5ffe350460c&tochange=898c2c656e4b156c323416ef0c859915f3fd2308

Suspecting Bug 1208673, since it's about HitTest and hit-testing seems to be broken here. Will know more definitively after mozregression gets through some inbound builds.

----
Cloned this as it has leaked into Aurora now. You can also use duckduckgo's hamburger menu as a test.
There's no need to clone bugs to get them fixed on branches. The correct way to do that is for the patch to be uplifted, on the original bug.

And note that the original bug has a pending needinfo=thinker (the patch author) to do just that.

Hence, closing (by duping back to the original bug). Note also that while the original bug is marked FIXED, it has firefox45 status flags as "tracking: +" and "affected".
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226904
No longer blocks: 1228279, 1234768, 1208673, 1230072
status-firefox46: affected → ---
No longer depends on: 1235979, 1226904
You need to log in before you can comment on or make changes to this bug.