Status

()

P3
normal
VERIFIED DUPLICATE of bug 141900
17 years ago
17 years ago

People

(Reporter: danielpeng, Assigned: kinmoz)

Tracking

({perf})

Trunk
mozilla1.1beta
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
With Mozilla 0.9.8 on a PII-300 running Mandrake Linux 8.1, I can type
significantly faster than Mozilla renders my typing into the textboxes at the
right side of the page.

Oddly, Bug #114945 (Text input into the form's input area) works for me.
(Reporter)

Comment 1

17 years ago
Sorry, I meant Mandrake Linux 8.0.
Keywords: perf
(Assignee)

Comment 2

17 years ago
Note to myself:

The page is made up of a bunch of absolute positioned divs. Typing in the
textfield in the div positioned on the right is causing all the other divs to
repaint too, so we end up painting the entire page with each keystroke. Need to
figure out why these invalidations/reflows are leaking out of the textfield.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3
Target Milestone: --- → mozilla1.0
Moving to Moz1.1
Target Milestone: mozilla1.0 → mozilla1.1

Updated

17 years ago
Depends on: 135146

Comment 4

17 years ago
Seeing even on Celeron-566 machine and RedHat Linux
(Assignee)

Comment 5

17 years ago
I can't access http://140.180.156.177/ anymore, but if I recall correctly, it
was a page with an absolutely positioned textfield, which when you typed in it,
was causing everything below it to reflow and repaint. It also had lots of
images on the page.

I think this page was a combination of all the problems pointed out in 141900.
Daniel, is there anyway we can get access to the page again? Or could you
download a trunk build that is from 06/14/02 8am or later and verify that the
problem no longer exists?

*** This bug has been marked as a duplicate of 141900 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Depends on: 141900
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

17 years ago
Page is available at http://67.80.87.243:8080/ .
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.1alpha → mozilla1.1beta
(Assignee)

Comment 7

17 years ago
I just confirmed that typing in the text widgets at http://67.80.87.243:8080/ is
faster than it used to be ... rendering keeps up with my typing fast and
furiously on a 500Mhz PIII running Linux, 1Ghz PIII running Win2k and a Mac G3
running 0S9

Daniel was there a reason why you reopened this bug? If not, I'm going to
re-resolve it as a dup of bug 141900.
(Assignee)

Comment 8

17 years ago

*** This bug has been marked as a duplicate of 141900 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.