Crash // assertion fail in nsHtml5TreeBuilder::adoptionAgencyEndTag

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: rory, Unassigned)

Tracking

(4 keywords)

46 Branch
x86_64
Linux
assertion, crash, html5, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

113 bytes, text/html
Details
(Reporter)

Description

3 years ago
Created attachment 8703346 [details]
test case

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Steps to reproduce:

Open the attached test case in firefox nightly, 46.0a1.


Actual results:

Firefox tab crashes


Expected results:

No crash
(Reporter)

Updated

3 years ago
Keywords: assertion, crash, html5
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

3 years ago
What's your Linux distribution? Please reproduce the crash with a build from mozilla.org, submit the crash report, then post the report ID from about:crashes in a comment here.
https://developer.mozilla.org/en-US/docs/How_to_get_a_stacktrace_for_a_bug_report

―――――

Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
20160102030217

Works for me in Linux Mint KDE.
Severity: normal → critical
Flags: needinfo?(rory)
Keywords: testcase
(Reporter)

Comment 2

3 years ago
I'm using Arch. I cannot reproduce this with the latest from https://nightly.mozilla.org/ -- perhaps it was an oddity in my build?

I'll mark this as INVALID for now, thanks for the stacktrace links.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(rory)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.