The default bug view has changed. See this FAQ.

crash [@ mozilla::dom::BroadcastChannelBinding::GetConstructorObjectHandle]

RESOLVED DUPLICATE of bug 1218473

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1218473
a year ago
a year ago

People

(Reporter: smaug, Unassigned)

Tracking

36 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

I was just looking at nightly crash reports and noticed this quite high.

https://crash-stats.mozilla.com/signature/?product=Firefox&version=46.0a1&date=%3C2016-01-03T14%3A12%3A01&date=%3E%3D2015-12-27T14%3A12%3A01&signature=mozilla%3A%3Adom%3A%3ABroadcastChannelBinding%3A%3AGetConstructorObjectHandle&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&page=1#reports

We're crashing somewhere in generated code.
And this is a recent regression (first appearance 2015-12-17) or we used to crash elsewhere before.
Duplicate of this bug: 1236401
Crash Signature: [@ mozilla::dom::BroadcastChannelBinding::GetConstructorObjectHandle]
Those crash reports seem to be fingering line 584 in BroadcastChannelBinding.cpp, which is:

    CreateInterfaceObjects(aCx, aGlobal, protoAndIfaceCache, aDefineOnGlobal);

There's nothing obvious to crash there...

Note also that I see no codegen changes around 2015-12-17.

I do see some maybe-relevant worker changes: bug 1233171, bug 901097.
Had perma startup crashes with this signature and Firefox 46.0a1 20160101 32 bit on Windows 8.1 64 bit after I upgraded the Intel HD graphics driver from 15.36.24.4264 to 15.36.28.4332 (that's the version number on the intel homepage, only the last version part matches the driver version). Newer builds also permacrashed on startup but with different signatures, see bug 1237240.

That new driver version got released shortly (2015-12-14 or 2015-12-11, dates on list and details page are different) before it's first appearance here (2015-12-17): https://downloadcenter.intel.com/download/25588/Intel-Graphics-Driver-for-Windows-7-8-1-15-36-28-4332-

Issue disappeared with Optimus disabled and after downgrade and upgrade of Intel HD driver.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1218473
You need to log in before you can comment on or make changes to this bug.