Intermittent attachments_test.js | Attachment picking and sending tests Test Suite A contact can be enclosed as attachment

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::SMS
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

I can't not reproduce it locally. It might need a slow environment or debug on server.

Hi Oleg, do you think that it's same issue like bug 1179604 that we should wait for the send button after switch back from activity?
Flags: needinfo?(azasypkin)
Yeah, either this or it takes too much time to open activity for some reason, easy to check if we wrap test body to something like:

test('....', function() {

try {
  ....test....
} catch(e) {
  assert(false, "message: " + (e.message || e.name) + 'stack: ' + (e.stack && e.stack.replace(/\n/g, '|')))
}
});

+ update tests/taskcluster config files to run only Gij and only this test file :)
Flags: needinfo?(azasypkin)

Updated

3 years ago
Assignee: nobody → schung
Unassign myself since I can not reproduce it in the local/docker/remote service with only test(https://github.com/mozilla-b2g/gaia/pull/33804). I only see a retry once while running on server(https://treeherder.mozilla.org/logviewer.html#?job_id=3354554&repo=gaia) but it seems unrelated.
Assignee: schung → nobody
Maybe it's a very low-rate intermittent and we shouldn't bother ? Let's see if we get more reports.
I was not able to reproduce the issue on my local docker as well, 50 runs on normal setup + 50 runs on very slow docker setup - so, right, hopefully it's very low-rate intermittent.

Although still want to run this test altogether with the rest of messages test to see if it makes any difference - I had similar issue in the past, when test was failing only when it was run with few more test suites.
I'm retriggering a lot of test runs in https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=168568ddddc2ff006dc795824829612bbf1089ed&selectedJob=3376201 for bug 1165765. attachments_test is in this run as well so we'll see.
Duplicate of this bug: 1238306
So looks like there are no any failures related to attachments in the test run from comment 6. Moreover as per bug 1236248 comment 7 - there were no any attachment test failures in 60 runs - so it doesn't look like real intermittent issue that deserves investigation at all.

I will keep eye on it and will close in a week if rate will be zero or close to it.
Well, no more complaints about this intermittent so closing for now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.