Closed Bug 12365 Opened 21 years ago Closed 21 years ago

cells with <br> alone considered empty

Categories

(Core :: Layout: Tables, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 10036

People

(Reporter: webmaster, Assigned: karnaze)

References

()

Details

(Whiteboard: [TESTCASE])

Attachments

(1 file)

Does not interpret the default stylesheet correctly. The background images for
certain tags are not rendered as they should be.
Assignee: don → karnaze
Component: Browser-General → HTMLTables
Summary: CSS error → cells with <br> alone considered empty
Whiteboard: [TESTCASE]
Moving this to HTMLTables.  Changing title from "CSS Error" to "cells with <br>
alone considered empty".

The problem in this page is that many of the lines are background images on
cells that are simply <td><br></td>.  According to CSS, backgrounds for empty
cells are not drawn.

What is happening here is that <br> is not being considered content for the
purposes of determining if a cell is empty.  I think it should be (it's kinda
like an escaped \0x0A).  Furthermore, that seems to be compatible with past
browsers: the author wouldn't have put the <br> if it didn't trigger some other
browser to draw the background.

Thus, more formally (using my testcase):

STEPS TO REPRODUCE: Load attached testcase.

EXPECTED BEHAVIOR: Second and third cells of second row red.

CURRENT BEHAVIOR: Only the third cell is red.
To finish what I was saying...

DOES NOT WORK CORRECTLY IN:
 * Linux, apprunner, 1999-08-20-13-M10

WORKS (ALMOST) CORRECTLY IN:
 * NN 4.6 Linux (except the cells aren't red, but you can see by the borders
that only the first cell is being considered empty)
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
This issue was discussed in bug 10036.
I'm marking this a duplicate.


*** This bug has been marked as a duplicate of 10036 ***
Resetting QA contact from leger.
Status: RESOLVED → VERIFIED
Verified dup of #10036
You need to log in before you can comment on or make changes to this bug.