Closed Bug 1236529 Opened 7 years ago Closed 7 years ago

Fix about:telemetry ping rendering & updating when changing views & reloading

Categories

(Toolkit :: Telemetry, defect, P1)

defect
Points:
1

Tracking

()

RESOLVED FIXED
mozilla46
Tracking Status
firefox46 --- fixed

People

(Reporter: gfritzsche, Assigned: gfritzsche)

References

Details

(Keywords: regression, Whiteboard: [measurement:client])

Attachments

(1 file)

STR:
* go to about:telemetry
* choose "archived ping"
* choose "raw json" display
* reload

Expected:
Raw ping display.

Actual:
A "null" line, followed by the structured ping display.
Assignee: nobody → gfritzsche
Points: --- → 1
Priority: P2 → P1
Duplicate of this bug: 1234590
This fixes the ping rendering updating issues i see here, from reloading to flipping through views and archived pings. Would be happy to have a second look at it by you though. One thing im not so happy about is how PingPicker.update() looks now, but i dont think it can be improved too much without any bigger refactoring (and we need the change tracking there to not lose states all the time).
Attachment #8704573 - Flags: review?(alessio.placitelli)
Summary: Reloading about:telemetry shows "null" raw ping data section → Fix about:telemetry ping rendering & updating when changing views & reloading
Comment on attachment 8704573 [details] [diff] [review]
Fix about:telemetry ping rendering

Review of attachment 8704573 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good. I agree with you, I'm not sure this could look much better without a refactoring.
Attachment #8704573 - Flags: review?(alessio.placitelli) → review+
https://hg.mozilla.org/mozilla-central/rev/a26f8e0d6463
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
You need to log in before you can comment on or make changes to this bug.