If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Animated GIFs aren't played back with as many loops as defined in GIF file

RESOLVED DUPLICATE of bug 1255497

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 1255497
2 years ago
2 years ago

People

(Reporter: Axel, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8703674 [details]
Can't run tasks.gif

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

I created an animated GIF that's supposed to repeat once (loop: 2).


Actual results:

While the GIF is played back correctly in IE, Firefox only plays it once, although the animation should be played back twice.


Expected results:

The animated GIF (see attachment) should be correctly played back twice.

Updated

2 years ago
Component: Untriaged → ImageLib
Product: Firefox → Core

Comment 1

2 years ago
I tried an old version, FF8, and the gif has only one run too. So old issue maybe.
Reproduced in Firefox, works as expected in Chrome.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 42 Branch → Trunk
:seth, can you comment to the bug?
Flags: needinfo?(seth)

Updated

2 years ago
Whiteboard: [gfx-noted]
I think this is a dupe bug 1255497. If not please re-open.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(seth)
Resolution: --- → DUPLICATE
Duplicate of bug: 1255497
(Reporter)

Comment 5

2 years ago
Interesting argumentation in the referenced Chromium thread ... Well, yes, you could perfectly argue that way. I feel using the word "loop" has been a bad decision. "Rewind", "Replay" or similar would have been a better choice. But it's too late now to argue on that.
You need to log in before you can comment on or make changes to this bug.