Lightning calendar disappeared with 38.5.0 update

RESOLVED INCOMPLETE

Status

Thunderbird
Untriaged
RESOLVED INCOMPLETE
2 years ago
a year ago

People

(Reporter: blin10@msn.com, Unassigned)

Tracking

(Blocks: 1 bug)

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151221130713

Steps to reproduce:

Restarted TB several times and restarted pc several times over the last few days since the latest TB update.  Was afraid to add the Lightening extension again for fear of loosing my preexisting entries.  Finally added it (it was not  listed anymore) and it reappeared along with my entries.


Actual results:

Was afraid to add the Lightening extension again for fear of loosing my preexisting entries.  Finally added it (it was not  listed anymore) and it reappeared along with my entries.  I never saw the normal "check existing extensions..." message when I was asked to restart TB after the update.


Expected results:

Calendar should not have disappeared.

Comment 1

2 years ago
You mean, Lightning was not listed in addons?
Blocks: 1215828
Flags: needinfo?(blin10)
(Reporter)

Comment 2

2 years ago
Correct.  Lightening was not listed in addons.  I have had it for years so it is not something new to me.
Flags: needinfo?(blin10)

Comment 3

2 years ago
Please answer, is your file system for the partition(s) for both, TB installation location and TB profile location NTFS?

And please test and tell us if this workaround works....
copy
{TB-program-installation}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
to
{TB-profile}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
** profile info https://support.mozilla.org/en-US/kb/profiles-tb#w_how-to-find-your-profile
After a restart does it work again as expected?
Flags: needinfo?(blin10)
(Reporter)

Comment 4

2 years ago
Yes, NTFS.

I did not test your recommendations as I have already regained Lightening as described in my original post. 

Thanks.
Flags: needinfo?(blin10)

Comment 5

2 years ago
I had this exact same problem (on M$ Windows-7), all files/content, etc is on local connected disk (laptop) - I don't have anything exotic in terms of setup.  I see that the lightning add-on is there with the version number 4.0.5.0 but am unable to get the calendar tab and don't see the usual 2 icons near the search box (lightning, it seems, has simply completely vanished).

I was able to get calendar back by installing an older version of the lightning add-on (namely 4.0.4.1).

I just upgraded to Thunderbird 38.5.1 and have the same exact problem - lightning/calendar is gone.  I restarted, enabled and disabled the lightning add-on (4.0.5.1) to no avail.

Comment 6

2 years ago
I am seeing the following error messages early on in the 'Error Console',

Timestamp: 2016-01-09 1:53:48 PM
Error: Error opening input stream (invalid filename?): file:///C:/Users/my_username/AppData/Roaming/Thunderbird/Profiles/8tluuv5l.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js (file:///C:/Users/my_username/AppData/Roaming/Thunderbird/Profiles/8tluuv5l.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js)
Source File: resource://calendar/modules/calUtils.jsm
Line: 51


Timestamp: 2016-01-09 1:53:48 PM
Error: ReferenceError: calAlarm is not defined
Source File: file:///C:/Users/my_username/AppData/Roaming/Thunderbird/Profiles/8tluuv5l.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 40


While creating services from category 'profile-after-change', could not create service for entry 'deleted-items-manager', contract ID '@mozilla.org/calendar/deleted-items-manager;1'

Comment 7

2 years ago
For what its worth - I don't seem to have a "calendar-js" sub-directory; I followed the path noted in the error (see message above) and noticed that I wasn't able to read/see the file (or reach the directory as a whole).  Not sure why its not there; I've never fiddled with any of the files/directories...  There is however a "calUtils.jsm" in the "modules" directory.

Why did this mishap occur (a google search reveals that others seem to be complaining of the same problem) ?  Why did the sub-directory vanish ?  How do I recreate the required files needed (or can they be copied off from somewhere) ?

I make the assumption that once the missing file(s) appear my problems would be solved - not sure this is true.

Comment 8

2 years ago
Tim, do you have anything that might my syncing your profile, such as using Roaming Profiles on Windows? Or perhaps using something like Dropbox to sync profiles?

Comment 9

2 years ago
Hi Kent, nothing.  My profile is static on my laptop - it is not getting sync'ed anywhere.  I'm not using "roaming" (in fact, I don't even know anything about it); so I'm pretty much a vanilla user connecting to the corporate exchange for email.  For some strange reason, a TB update seems to annihilate "calendar-js" directory cause when I manually reinstall Lightning the directory is reinstated (ie. is created).  Is there anything in the Thunderbird update which touches/updates/removes that directory ?

Comment 10

2 years ago
"I'm pretty much a vanilla user connecting to the corporate exchange for email"

That sounds to me like you are a member of a domain in a corporate environment, if true then your domain controller can affect your configuration.

Comment 11

2 years ago
So what should I do to check that my configuration is NOT "affected".  I find it a bit difficult to understand how the corporate environment is affecting an update of Thunderbird when the profile directory is in the same place (within the file hierarchy) and when I manually install Lightning the "calendar-js" is created, etc.  In other words, if there is something that is not allowing the creation of "calendar-js" during an update wouldn't it rear its ugly head while doing a manual install as well ?  Why does this only occur on an update of TB ?  How can someone adversely affect a TB update ?  More importantly, how can I debug this ? Can a TB update check to make sure that what it requires/thinks is happening is indeed taking place (ie. directories are created, etc) ?  I tried to do an exhaustive search for the missing directory (ie. "calendar-js") to see if it, mysteriously, is getting redirected to a different path and found the following two paths,

 - C:\Users\my_username\AppData\Roaming\Thunderbird\Profiles\8tluuv5l.default\extensions\{e2fda1a4...
 - C:\ProgramFiles(x86)\Mozilla Thunderbird\distribution\extensions\{e2fda1a4...

Could it be that somehow the update is updating/creating the directory somewhere else (ie. ProgramFiles) other than where lightning is expecting it (in the AppData dir) ?  If so, why and why isn't there a symbolic link or something that would point at the new place ?

Do please give me a bit more insight to know how to debug this so that other TB don't get affected by this mysterious oddity.  Feel free to let me know if you need any further info (or debug data) from me.

Comment 12

2 years ago
Tim, from our perspective the issues in the bug are likely a variation of what is a much more serious issue, bug 1211160. All of the evidence is that there is some sort of interaction between corporate environments running Windows, usually with roaming profiles, and the Thunderbird update mechanism. We are still trying to figure out how to debug this. It is not clear that your issue is the same underlying mechanism, but it is likely.

If someone could figure out a way to duplicate this, particularly in a way that a developer could simulate, it would be enormously helpful. It's hard to give you instructions for that, since we don't know ourselves.

Comment 13

2 years ago
I'd be more than happy to run any debug code you guys would like me to in order to give further visibility into the process (I'm sure a few printf's injected in the proper places would give alot of insight).  It would be useful to have a "debug" add-on for just such occasions :-)

It is natural that there are 2 "calendar-js" directories/instances ?  Could it be as simple as, a TB update updates "ProgramFiles" (and removes the "AppData" tree via the previous version uninstall possibly) while a manual install of lightning updates/installs "calendar-js" in "AppData".  Lightning seems to want the "AppData" instance.

The bug sited (1211160) talks about potentially chrome.manifest being out of sync, in my case the entire "calendar-js" directory is not created in the "AppData" tree.  This is not to say they are not related but I'd assume its easier to investigate why an entire directory is not being created.

Comment 14

2 years ago
While doing some tests for bug 1211160, I managed to create a condition that caused the Lightning addon to disappear on update, which I will add here as a hint.

The coding issue caused the copy of files from distribution/extensions to the profile to fail, which triggered rollback. Rather than role back to the previous condition (addon installed), it removed the addon completely. That is probably not the behavior we would want.

Comment 15

2 years ago
Good to hear and MANY thanks for the follow-up.  At least the bug/situation is now understood and a solution is forth coming - much appreciated !!

Comment 16

2 years ago
Tim, bug 1211160 has been fixed. Do you still see the problem when using a current version of Thunderbird?
Flags: needinfo?(blin10)
Summary: Lightening calendar disappeared with 38.5.0 update → Lightning calendar disappeared with 38.5.0 update
Havn't heard from Tim, so => incomplete
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(blin10)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.