Frequent artifacting when scrolling medium.com articles w/ APZ enabled

RESOLVED DUPLICATE of bug 1251894

Status

()

Core
Panning and Zooming
RESOLVED DUPLICATE of bug 1251894
2 years ago
2 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox46 affected)

Details

(Whiteboard: [gfx-noted], URL)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Feel free to dupe this to another bug as-needed. It's hard to get a sense of which specific issues overlap across different websites going through the deps of bug 1013364. See also bug 1188532 which might be related.

On the page linked from the URL field (and other medium.com articles), I frequently see text duplication/overlaying and images flashing in and out when scrolling with the mousewheel. No issues with APZ disabled or when using the arrow keys to scroll.

Reproduced on Win10. It's reproducible on Linux as well, but I find it more difficult as scrolling seems hella-laggy in general. In case it matters, this is on a HiDPI laptop (4K screen).
I can't repro on my piddly non-4k screens. That being said this might be a dupe of bug 1201996; that's the closest one I can think of.

Comment 2

2 years ago
See the text tearing/blurring in this video I took on win10 e10s today:

  https://www.dropbox.com/s/dxbkwvaau4tiyu1/VID_20160108_123523.mp4?dl=0
Created attachment 8705744 [details]
Frame from bkelly's video

I screenshotted a frame from bkelly's video which shows the issue (I think).
Based on the investigation in bug 1201996, medium.com uses a canvas that they draw into on scroll events, or something like that. So it's quite possible that this duplicate-drawing stuff is a stale canvas element being combined with content scrolling on top.

Comment 6

2 years ago
That would also explain why the artifacting only happens on the first scroll-through of the page.  The canvas is complete after that.
I've also seen some blurring on the first scrollthrough on Medium, though not nearly as severe as the screen shot. I don't have a 4k monitor.

Comment 8

2 years ago
I don't have a 4k monitor either.  Note, the screenshot looks worse than what I see since its very transient.
Duplicate of this bug: 1238583

Updated

2 years ago
Whiteboard: [gfx-noted]
Duplicate of this bug: 1252317
Created attachment 8728337 [details]
scrolling-on-medium.gif

I also reproduce this on dev edition (FF46) on windows 10.
Here's a gif recording while scrolling with the mouse wheel.
I'm pretty sure this was fixed bug 1251894, which has already landed on Nightly.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1251894
You need to log in before you can comment on or make changes to this bug.