Non-existent localized page request does not honor en-us/en in Accept-Language

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Tonnes, Assigned: pollti)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
When visiting the URL above for a yet to be localized article today by using the URL for Dutch, I got a warning in Dutch as usual but was offered the French version instead of US English. Instead, the order of the languages defined in Firefox should be honored and therefore the English version should appear, which in my case was set to nl,en-us,en,fy,fr at that point. When substituting fr for de (or rather: add German before French to use nl,en-us,en,fy,de,fr), the German page was offered. Apparently the first 4 locales defined were skipped, which may be OK for nl and fy (as they don’t exist yet), but en-us and en should definitely be accepted as usual. The same thing happens when checking e.g. the Romanian locale (https://support.mozilla.org/ro/kb/tab-groups-removal): Romanian warning, French content.

STR
1. Set the accepted languages to nl,en-us,en,fr,de (top-bottom order in Firefox)
2. Visit https://support.mozilla.org/nl/kb/tab-groups-removal

Actual results:
Page is offered in French

Expected results:
Page should be offered in English

Note that this is a page currently still in the Admin category and hence not public (though marked ready for l10n), but that probably shouldn’t make a difference. I also see a little resemblance to bug 639818.
(Assignee)

Comment 1

3 years ago
I also saw this artcile (https://support.mozilla.org/de/kb/tab-groups-removal) in French some days ago (the German l10n of the article has been created later). The languages are set to de,de-de,de-ch,de-at,en-us,en,en-gb,fr here. When visiting https://support.mozilla.org/ro/kb/tab-groups-removal, I see the German content now. However, I can still reproduce this behavior in other articles like https://support.mozilla.org/ro/kb/forum-response-signed-add-ons.
(Reporter)

Comment 2

3 years ago
Since the en-US page was moved out of Administration and a Dutch version is available, the /nl/ URL is a bad example, please use URLs for e.g. Romanian instead. Pages are redirected to the preferred locale when localized (not sure if this was changed from Sumo offering en-US by default recently) but the issue simply occurs when setting en-us and en 1st and 2nd (on top in the UI), so they are obviously skipped.
(Assignee)

Comment 3

3 years ago
My guess is that en-US/en is not included in doc.translations and https://github.com/mozilla/kitsune/blob/f903ec269cbbbf5d32dd95db7e705cf2a5812e71/kitsune/wiki/views.py#L1530 fails for those. I'll try to check that in the next days.
PR: https://github.com/mozilla/kitsune/pull/2765
Pushed to prod.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Assignee: nobody → pollti
(Assignee)

Comment 5

3 years ago
mythmon, are you sure you added the correct PR here? I think this is https://github.com/mozilla/kitsune/pull/2764.
Thanks Tim, you're right. The correct PR is #2764.
You need to log in before you can comment on or make changes to this bug.