Closed Bug 123664 Opened 23 years ago Closed 21 years ago

Add "copy" to the context menu

Categories

(Other Applications :: ChatZilla, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: tpowellmoz, Assigned: rginda)

References

Details

When joined to a channel in chatzilla, for example #mozillazine, you can't copy
the text in the window by selecting it and then doing ctrl+c or right-click
copy. It seems to work with Copy from chatzilla's Edit menu, but that is not as
noticable. I actually didn't think it worked at all until a friend pointed out
the Edit menu.

Observed with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020202
Confirmed the bug with Mozilla 1.0.1RC2 on WinXP
Confirming the bug with Mozilla 1.1 on WinXP
Confirming Trunk build September 1st 2002.

In other words the bug should be named:

Add "Copy" to the right click context menu

However, CTRL+C works for me
We are also having this problem regularly in email.
Here is how can I make it work in Mozilla Build ID: 2002111512 on WinXP:
1. Select the text with the mouse
2. right on the selected text
3. don't click on copy, click on the windows title
4. switch to another window
5. switch back to the Chatzilla window
6. press Ctrl+C
7. now it works!

Seems to me a focus issue. Te focus is taken after selecting with mouse. If you
switch the focus between windows and come back to Chatzilla. The focus returns
to the selected text.
You are also able to copy text if you DO NOT RELEASE LEFT MOUSEBUTTON until you
have pressed ctrl+c

Thus possibly it might be some weird noMouseUp isseu too ?

The focus issue should be fixed now, so changing summary.
Summary: Can't copy text using Ctrl+C or right click → Add "copy" to the context menu
Depends on: 229545
Chatzilla 0.9.54 is now available and has landed on the trunk (cvs). This should
have resolved this bug; if it has not, please reopen it.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.