Hebrew: question mark displayed at the end of the sentence in default browser dialog

RESOLVED DUPLICATE of bug 1238756

Status

()

Core
Localization
RESOLVED DUPLICATE of bug 1238756
2 years ago
a year ago

People

(Reporter: lmandel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8703803 [details]
Partially translated default browser message

Reported by a third party to me via e-mail.

The 'Default web browser' pop-up message is partially translated in English and partly in Hebrew

INSTRUCTIONS:
0. System running OS X 10.11.2 GM
1. Install 3rd browser app (e.g. Firefox)
2. Launch FireFox for the first time > See the 'Default web browser' pop-up message

ACTUAL RESULTS:
1.LTR string, the question mark appear in the right side instead of the left side.
2.The buttons are not localized
Untranslated buttons: that's expected, given that Hebrew is still missing strings
https://l10n.mozilla.org/shipping/dashboard?tree=fx_aurora&tree=fx_beta&locale=he

For example the 'set as default browser' is translated on Aurora, not on Beta yet. The 'Not now' button doesn't seem to be translated anywhere.

https://hg.mozilla.org/releases/l10n/mozilla-beta/he/file/default/browser/chrome/browser/shellservice.properties

As for the question mark, Tomer can definitely tell if it's broken. As far as I know Hebrew doesn't mirror the ? character, but I'd expect this to have the question mark at the beginning and Firefox at the end.

setDefaultBrowserMessage=%S אינו מוגדר כרגע כדפדפן ברירת המחדל שלך. האם ברצונך להפוך אותו לדפדפן ברירת המחדל שלך?
Summary: Default browser message partially translated (Hebrew) → Hebrew: question mark displayed at the end of the sentence in default browser dialog

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1238756
You need to log in before you can comment on or make changes to this bug.