Some mochitests fail under lldb: We expected 'tests/dom/media/test/320x240.ogv' to exist, but it doesn't!

RESOLVED DUPLICATE of bug 1333259

Status

Testing
Mochitest
RESOLVED DUPLICATE of bug 1333259
2 years ago
7 months ago

People

(Reporter: haik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
When running the test_gmp_playback.html mochitest under lldb, 4 tests fail with the following output.

failed | We expected 'tests/dom/media/test/320x240.ogv' to exist, but it doesn't!
failed | We expected 'tests/dom/media/test/r11025_s16_c1.wav' to exist, but it doesn't!
failed | We expected 'tests/dom/media/test/bug461281.ogg' to exist, but it doesn't!
failed | We expected 'tests/dom/media/test/seek.webm' to exist, but it doesn't!

And the console has

TEST-UNEXPECTED-FAIL | /tests/dom/media/test/test_gmp_playback.html | We expected 'tests/dom/media/test/320x240.ogv' to exist, but it doesn't! - expected: PASS
TEST-UNEXPECTED-FAIL | /tests/dom/media/test/test_gmp_playback.html | We expected 'tests/dom/media/test/r11025_s16_c1.wav' to exist, but it doesn't! - expected: PASS
TEST-UNEXPECTED-FAIL | /tests/dom/media/test/test_gmp_playback.html | We expected 'tests/dom/media/test/bug461281.ogg' to exist, but it doesn't! - expected: PASS
TEST-UNEXPECTED-FAIL | /tests/dom/media/test/test_gmp_playback.html | We expected 'tests/dom/media/test/seek.webm' to exist, but it doesn't! - expected: PASS

The test doesn't report any errors when run without the debugger. I'm running the test with the following command.

$ ./mach mochitest --debugger lldb --debugger-args "-o run" dom/media/test/test_gmp_playback.html

This is on Mac OS X El Capitan.

$ uname -mprsv
Darwin 15.2.0 Darwin Kernel Version 15.2.0: Fri Nov 13 19:56:56 PST 2015; root:xnu-3248.20.55~2/RELEASE_X86_64 x86_64 i386

$ lldb -v
lldb-340.4.119

$ hg heads
changeset:   276928:c5cb194cc9cb
tag:         tip
parent:      276799:8e54ec9a12f2
parent:      276927:fbb48f4efd21
user:        Carsten "Tomcat" Book <cbook@mozilla.com>
date:        Fri Dec 18 15:23:39 2015 +0100
summary:     merge mozilla-inbound to mozilla-central a=merge

$ hg summary
parent: 276928:c5cb194cc9cb tip
 merge mozilla-inbound to mozilla-central a=merge
branch: default
commit: (clean)
update: (current)
mq:     4 unapplied
(Reporter)

Comment 1

2 years ago
$ ls tests/dom/media/test/320x240.ogv
ls: tests/dom/media/test/320x240.ogv: No such file or directory

$ find . -name 320x240.ogv
./dom/media/test/320x240.ogv
./embedding/test/320x240.ogv
./obj-dbg.noindex/_tests/testing/mochitest/chrome/embedding/test/320x240.ogv
./obj-dbg.noindex/_tests/testing/mochitest/tests/dom/media/test/320x240.ogv
(Reporter)

Comment 2

7 months ago
The test was removed by the fix for Bug 1333259 "Remove test_gmp_playback.html". I don't have another example of a failing test. Closing this bug.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1333259
You need to log in before you can comment on or make changes to this bug.