"Sending of message failed" whenever I try to send a mail in 0.9.8

VERIFIED INVALID

Status

MailNews Core
Backend
--
critical
VERIFIED INVALID
16 years ago
10 years ago

People

(Reporter: mozbug1, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415

Whenever I try to click the send button in the mail compose window I get two
dialog boxes.  One is a progress bar, and one says "Sending of message failed".
 This happens every time I try and send a mail.

Reproducible: Always
Steps to Reproduce:
1.  Compose a message.
2.  Click the send button.

This worked in 0.9.7
(Assignee)

Comment 1

16 years ago
can you try generating an SMTP log for us? 

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

any errors printed out in the JS console? (Tasks / Tools / JS Console)
(Reporter)

Comment 2

16 years ago
Shortly after I posted the bug mozilla ran away on me allocating memory.  I
don't know if it was related or not.  I will try debugging later when I can risk
freezing the system, but right now I can't.
(Reporter)

Comment 3

16 years ago
Created attachment 68018 [details]
debug file produced by mozilla

File obtained by debug instructions at
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Reporter)

Comment 4

16 years ago
OK I don't know what happend but now 0.9.7 doesn't work any more.  I installed
0.9.7 and 0.9.8 in seperate directories owned by root.  Now when I run 0.9.7
from its directory as me (not root) it is having the same problem.  I'm going to
remove my .mozilla and try again.
(Assignee)

Comment 5

16 years ago
since your problem is related to sending I need ya to generate a log for SMTP
instead of IMAP. So set your environment variable for SMTP. Thanks!
(Reporter)

Comment 6

16 years ago
OK I moved my .mozilla and restarted 0.9.8.  It was a disaster.  Not only didn't
the bug go away, but there we servral more.

When I first started up it converted my profile from my ancient netscape
profile.  My mail servers ended up with two INBOX's each and for some reason in
all the dialog boxes there was no text on the buttons.

I just copied and pasted from the web page last time, I'll reset debugging for
SMTP. 
(Reporter)

Comment 7

16 years ago
I restarted sendmail on my smtp server and everything is working now.  It's
funny how it didn't work for 0.9.8, then did work for 0.9.7, but then stopped
working for both.  I haven't seen the mozilla running away with memory problem
either.  So I guess this should makred as INVALID.  Someone should look into the
problem I had converting my netscape profile though.  Is there already a bug for
that?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
jks: already a bug for that: search bugzilla for '2 inbox' and you should find it.

verified invalid.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.