URL bar doesn't change after starting tabbed browsing in 0.9.8

VERIFIED DUPLICATE of bug 111086

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 111086
17 years ago
10 years ago

People

(Reporter: Brett Porter, Assigned: jag (Peter Annema))

Tracking

({qawanted})

Trunk
x86
Windows 2000
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
After opening a new tab, the URL bar no longer changes - it retains the URL of
the new tab, even when swapping tabs or clicking links within tabs.

Comment 1

17 years ago
wfm on Win95 with 0.98 release version.

Comment 2

17 years ago
*** Bug 127152 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
may be related to bug 90337

Comment 4

17 years ago
linux x86 2002-03-20-21

I'm also seeing this problem.  However, I have not yet determined how
to get it into this state consistently.

I have one window with multiple tabs that has no problem. I have another
window with multiple tabs that shows this problem.  The URL given in the
URL bar doesn't change when I switch tabs, or click on links within any
of the tabs, EXCEPT for the one tab!  It's as if the URL bar has managed
to "lock onto" one of the tabs, and the other tabs can no longer control
what is displayed there.

Comment 5

17 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

16 years ago
Ok, I've found a way to reproduce this.  For the purpose of this test,
_uncheck_ the following preference:

  Navigator->Tabbed Browsing->Tab Display->"Hide the tab bar when only one..."

(i.e. so that moz doesn't hide the tab bar when only one tab is open.)
Note that it doesn't matter whether this preference is off.  It just makes
it easier to explain the procedure (since I'll refer to "tab1", "tab2", etc.).

Here is the procedure to reproduce the problem:

1. Start moz

2. Go to www.accuweather.com

3. Enter a zip code and click "Go" button to go to the "My Local Page"

4. Now go to another website, for example, www.cnn.com

Note that all steps above are performed in "tab1", i.e. no new tabs

5. Right click on a link (e.g. the headline) and open it in a new tab ("tab2")

6. After tab2 is opened, observe that the URL displayed in the navigation
   toolbar is still www.cnn.com.  You can toggle between tab1 and tab2,
   and you'll see that the URL doesn't change

8. Now switch to tab1.  Close tab1.  So the original tab2 now becomes tab1.
   Observe that the URL is still www.cnn.com

9. Now go to any websites by using bookmarks or clicking on links
   (_not_ by typing in the URL bar).  No matter where you go, the URL
   is always www.cnn.com

10. Now if you go to a website, say www.slashdot.org, by typing in the
    URL bar, it will work, but after that the URL will always be
    www.slashdot.org no matter where you go, until you type in the
    URL bar again (at which point it sticks to that new URL, etc...)

So it seems that the URL is "locked onto" tab1 (or maybe it's
the tab that opens the problematic page?), and it seems to be
caused by some particular pages.  Maybe someone can look into this
(quite annoying) problem?

Btw, I've tested this on 3 machines (1) RH6.2 with 2002032717,
(2) RH7.2 with 2002040406, and (3) Win98SE with 0.9.9 release.
They all show the same problem.

Comment 7

16 years ago
The same problem also shows up on Windows 2000 with 0.9.9 release.

Here is a summary of my tests: after visiting some particular web pages
(e.g. the "My Local Page" on www.accuweather.com), the displayed URL
is locked onto one tab (i.e. doesn't change when switching to another tab
or opening a new tab).

Btw, I've tested this on 4 configurations: RH Linux 7.2 with 2002040406,
RH Linux 6.2 with 2002032717, Win98SE with 0.9.9 release, and Win2000 with
0.9.9 release.  They all show the same problem.

Could someone confirm my test results?

Comment 8

16 years ago
With 1.0 RC3, I still have the problem when opening a PDF file in a new tab. The
first time I do see the right URL, but if a switch to another tab then back, the
URL of the PDF doc doesn't display anymore.

Comment 9

16 years ago
this bug sounds like a version of bug 111086 but differs in that this bug sounds
like its about the URL never changing (apart from comment #6) whereas 111086 is
about it occasionally not changing

can we mark this and bug 127152 as duplicates of bug 111086?
if we don't, then bug 146740 is a duplicate of this bug

Updated

16 years ago
Keywords: qawanted
(Assignee)

Comment 10

16 years ago
Yeah, this is bug 111086.

*** This bug has been marked as a duplicate of 111086 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.