Closed Bug 1236737 Opened 4 years ago Closed 4 years ago

Intermittent browser_cmd_screenshot.js | This test exceeded the timeout threshold. It should be rewritten or split up.

Categories

(DevTools Graveyard :: Graphic Commandline and Toolbar, defect, P2)

Unspecified
Linux
defect

Tracking

(firefox50 fixed, firefox51 fixed)

RESOLVED FIXED
Firefox 51
Tracking Status
firefox50 --- fixed
firefox51 --- fixed

People

(Reporter: KWierso, Assigned: miker)

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 2 obsolete files)

Priority: -- → P1
Only seems to be an issue on Linux apart from one occurrence 6 months ago.
OS: Unspecified → Linux
This shouldn't be a P1.
Priority: P1 → P2
this affects linux32 about 1/3 times it runs.  I looked at some runs and this takes 40+ seconds to run, we get a timeout at 50 seconds- really I wonder if we need to just make the timeout longer here?
Flags: needinfo?(mratcliffe)
<moan>
I really wish we didn't crop the logs... whenever a test times out it would be great to see a complete log of that test and the one before.
</moan>

Anyhow, I will extend the timeout.
Assignee: nobody → mratcliffe
Flags: needinfo?(mratcliffe)
So it looks like this test sometimes gets held up by a cascade of GCs from previous tests. If only there was some way to pause the timer whilst GC is running.
can we do a better job forcing GC between tests?  Then again, end users will experience GC's in their browser and wonder why a page isn't rendering or being responsive.  This is only a common problem on linux32 non e10s from what I can tell- maybe we can just disable this test for linux32 only?
(In reply to Joel Maher ( :jmaher ) from comment #27)
> can we do a better job forcing GC between tests?  Then again, end users will
> experience GC's in their browser and wonder why a page isn't rendering or
> being responsive.  This is only a common problem on linux32 non e10s from
> what I can tell- maybe we can just disable this test for linux32 only?

That was my solution a couple of years ago. The JS guys spent time enhancing GC and said it should be a non-issue and it mostly is. The problem is that GCLI tests can open a panel / tooltip hundreds of times so the test after it is always gonna take a GC hit.

Anyhow, I have added a patch to increase the timeout to 90s... if that doesn't stop the timeouts we can disable the test.

It is a very small change so r=me
Attachment #8766750 - Attachment is obsolete: true
Attachment #8766751 - Attachment is obsolete: true
Attachment #8777295 - Flags: review+
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/c4fdd2f8e167
Stop intermittent timeouts in browser_cmd_screenshot.js r=me
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c4fdd2f8e167
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.