Open Bug 1236747 Opened 4 years ago Updated 7 months ago

Categorize SwedishHolidays.ics events to "Public holiday" or "De facto holiday"

Categories

(Calendar :: Website, defect)

All
Unspecified
defect
Not set

Tracking

(Not tracked)

People

(Reporter: public, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20151221154602

Steps to reproduce:

Subscribed to https://www.mozilla.org/media/caldata/SwedishHolidays.ics

Any calendar in https://www.mozilla.org/en-US/projects/calendar/holidays/ can be subscribed to to reproduce this issue.


Actual results:

Holidays do not distinguish between working days and non-working days.


Expected results:

Holiday calendars must be split into two categories
* Non-working holidays - Preferred to set with red background color
* Working holidays - Another background color than red

Because then "Holidays (non-working days)" can be marked with red background color, and Holidays (working days) with a different color, so people do not mix them.
Hardware: Unspecified → All
Flags: wanted-calendar1.0?
Flags: blocking-calendar1.0?
Version: unspecified → Trunk
I'd like to ask you to not play around with flags you don't know. Lightning 1.0 was already released on November 7, 2011. 

The differentiation between working days and non-working days cannot be done easily because it depends on the job you have and many people have to work on public holidays. The holiday calendars on the mentioned web page were provided by volunteer contributors. I don't think they will be changed according to your needs. But you can download, import, and modify the events in your local calendar copy as you like.
Component: Provider: ICS/WebDAV → Website
Flags: wanted-calendar1.0?
Flags: blocking-calendar1.0?
Changing the calendars is left to volunteers, so this isn't something we can do for all calendars. If there is a need to split up the Swedish Calendar because a large portion of the population observes either one or both categories, then please reopen this bug and provide the two files. We should then cross check with the original author of the last calendar file and possibly check evidence that this is actually the case.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
> Changing the calendars is left to volunteers

How do I modify the calendar myself then?
(In reply to Philipp Kewisch [:Fallen] from comment #2)
> Changing the calendars is left to volunteers, so this isn't something we can
> do for all calendars. If there is a need to split up the Swedish Calendar
> because a large portion of the population observes either one or both
> categories, then please reopen this bug and provide the two files. We should
> then cross check with the original author of the last calendar file and
> possibly check evidence that this is actually the case.

> Changing the calendars is left to volunteers

How do I modify the calendar myself then?
However you like. Copy and paste in some text file, or removing some items and saving under a different name...
(In reply to Philipp Kewisch [:Fallen] from comment #2)
> Changing the calendars is left to volunteers, so this isn't something we can
> do for all calendars. If there is a need to split up the Swedish Calendar
> because a large portion of the population observes either one or both
> categories, then please reopen this bug and provide the two files. We should
> then cross check with the original author of the last calendar file and
> possibly check evidence that this is actually the case.

Done. Can you please have a look?
Summary: Split holiday calendars into "Non-working holidays", and "Working holidays" → Split holiday calendars into "Public holidays", and "De facto holidays"
See the attached SplitSwedishHolidays.tar.gz
Summary: Split holiday calendars into "Public holidays", and "De facto holidays" → Split the Swedish Holidays calendar into "Public holidays", "De facto holidays", and "Daylight saving time"
Summary: Split the Swedish Holidays calendar into "Public holidays", "De facto holidays", and "Daylight saving time" → Split SwedishHolidays.ics to: SwedishPublicHolidays.ics, SwedishDeFactoHolidays.ics, SwedishDaylightSavingTime.ics
I looked at the official law web link for Swedish Holidays when I edited my calendars: http://www.riksdagen.se/sv/dokument-lagar/dokument/svensk-forfattningssamling/lag-1989253-om-allmanna-helgdagar_sfs-1989-253
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(philipp)
Resolution: WONTFIX → ---
Attachment #8856521 - Flags: review?(philipp)
What is going on? =)
Status: REOPENED → NEW
Comment on attachment 8856521 [details]
SplitSwedishHolidays.tar.gz

I don't think this is a particularly good idea, though I understand what you're saying. Too much trouble to set up more than one feed for "one thing".
Besides, the daylight savings is a schedulable as a recurring event.

For cases like this ideally the events would be marked with distinct categories. Then lightning allows you to (partially) set color.
Attachment #8856521 - Flags: feedback-
(In reply to Magnus Melin from comment #13)
> Comment on attachment 8856521 [details]
> SplitSwedishHolidays.tar.gz
> 
> I don't think this is a particularly good idea, though I understand what
> you're saying. Too much trouble to set up more than one feed for "one thing".
> Besides, the daylight savings is a schedulable as a recurring event.
> 
> For cases like this ideally the events would be marked with distinct
> categories. Then lightning allows you to (partially) set color.

The issue is that lightning only allows you to set different background colors for different calendars, so you still need to split them into different calendar files, right?

Comment on attachment 8856521 [details]
SplitSwedishHolidays.tar.gz

Sorry for the delay on this and not providing a better answer, but I'm not really sure how to proceed here. There have been a few changes in direction on this bug and Magnus has some concerns, so maybe you could restate what the issue is, provide some information on why it is a good idea, and we can see how we can best get these in.

Looking forward to hearing from you.

Flags: needinfo?(philipp)
Attachment #8856521 - Flags: review?(philipp)

(In reply to Magnus Melin [:mkmelin] from comment #13)

Comment on attachment 8856521 [details]
SplitSwedishHolidays.tar.gz

I don't think this is a particularly good idea, though I understand what
you're saying. Too much trouble to set up more than one feed for "one thing".
Besides, the daylight savings is a schedulable as a recurring event.

For cases like this ideally the events would be marked with distinct
categories. Then lightning allows you to (partially) set color.

Category colors are note set in Thunderbird 60.2.1 (Lightning 6.2.2.1) or later. Should I file a bug report for this?

(In reply to David Hedlund from comment #16)

(In reply to Magnus Melin [:mkmelin] from comment #13)

Comment on attachment 8856521 [details]
SplitSwedishHolidays.tar.gz

I don't think this is a particularly good idea, though I understand what
you're saying. Too much trouble to set up more than one feed for "one thing".
Besides, the daylight savings is a schedulable as a recurring event.

For cases like this ideally the events would be marked with distinct
categories. Then lightning allows you to (partially) set color.

Category colors are note set in Thunderbird 60.2.1 (Lightning 6.2.2.1) or later. Should I file a bug report for this?
I filed it at https://bugzilla.mozilla.org/show_bug.cgi?id=1544272

Depends on: 1544272
Depends on: 1534112
No longer depends on: 1544272

Sweden is a member of the European Union. European parliament votes to scrap daylight saving time from 2021 - https://www.theguardian.com/world/2019/mar/26/european-parliament-votes-to-scrap-daylight-saving-time-from-2021

Depends on: 1544287

For cases like this ideally the events would be marked with distinct
categories. Then lightning allows you to (partially) set color.

That's a good idea, I suggested: Add "De facto holiday" to calendar categories - https://bugzilla.mozilla.org/show_bug.cgi?id=1544287

Summary: Split SwedishHolidays.ics to: SwedishPublicHolidays.ics, SwedishDeFactoHolidays.ics, SwedishDaylightSavingTime.ics → Split SwedishHolidays.ics to: SwedishPublicHolidays.ics, SwedishDeFactoHolidays.ics
Summary: Split SwedishHolidays.ics to: SwedishPublicHolidays.ics, SwedishDeFactoHolidays.ics → Categorize SwedishHolidays.ics events to "Public holiday" or "De facto holiday"
You need to log in before you can comment on or make changes to this bug.