[Mac] Video and audio out of sync on integrated gpu

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
I've been noticing the video and audio falling out of sync a lot in the last few days on Nightly. It's particularly noticeable on this video here:

https://www.youtube.com/watch?v=4SyetdjWMuw
(Reporter)

Comment 1

3 years ago
I see a lot of frames being skipped in there. This is perhaps where the audio falls out of sync.
can you right click on the video window and select Stats for Nerds when you're seeing the A/V sync issue and copy here.

When you saying A/V sync issue, does the video appears to play properly but not in sync with the audio (e.g. a constant delay between audio and video), or does the video appear frozen while audio continue playing then when video resumes it is in sync again only to freeze again?
Flags: needinfo?(bgirard)
(Reporter)

Comment 3

3 years ago
I think this might only occur with the Integrated GPU and not the discrete. My resolution is high and the Intel GPU is not strong enough.

I see the same frame stick on the screen for a bit (half a second worth or longer), then it jumps ahead and skips frame to 'catch-up' but the audio is now unsync.

I'll post the stats when I reproduce again.
Priority: -- → P2
(In reply to Benoit Girard (:BenWa) from comment #3)
> My resolution is high and the Intel GPU is not strong enough.

Can you post the graphics section of about:support and tell us your monitor resolution?
(Reporter)

Comment 5

3 years ago
Created attachment 8712204 [details]
about:support
Flags: needinfo?(bgirard)
(Reporter)

Comment 6

3 years ago
This is running at the 1920x1200 2x retina scaled down to the mac retina screen at 2880×1800.
(Reporter)

Comment 7

3 years ago
I tried forcing this as much as possible and I can't reproduce this. I'll re-open if I see this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

3 years ago
Summary: [Mac] Video and audio out of sync → [Mac] Video and audio out of sync on integrated gpu
You need to log in before you can comment on or make changes to this bug.