If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

“Load more” button does not work in apps listing pages

VERIFIED FIXED in 2016-01-12

Status

Marketplace
API
P1
major
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: ValentinaP, Unassigned)

Tracking

Avenir
2016-01-12
x86_64
Windows 7
Points:
---

Details

(Reporter)

Description

2 years ago
Steps to reproduce:
1. Load MP-stage page https://marketplace.allizom.org/
2. Go to "Popular" page
3. Click “Load more” blue button

Expected results:
More apps are loaded.

Actual results:
Nothing happens. Button label is changed to “Try again”.

Notes/Issues:
Verified on MP-stage FF46(Win7, Android 4.4). Issue is only reproducing on MP-stage.
Screencast for this issue: http://screencast.com/t/u0CNLDWMQDXZ

Updated

2 years ago
Priority: -- → P4
(Reporter)

Comment 1

2 years ago
This issue is now in MP-production.
Please see the screenshot: http://screencast.com/t/Sw1DSnHXjJf

Updated

2 years ago
Severity: normal → major
Priority: P4 → P1
It's a backwards-incompatible change in our API responses.

Our API responses for lists contain a "meta" property that indicates the url for the next/previous pages. The old version used to be a relative URL, without the hostname, but the newest version returns the hostname, and that confuses clients like fireplace (or transonic in bug 1238617) that expect to need to concatenate this URL with the api hostname - which it needs to do to sometimes use the CDN instead of the regular hostname.
Component: Consumer Pages → API

Updated

2 years ago
Duplicate of this bug: 1238617
Switched back to relative URLs.

https://github.com/mozilla/zamboni/commit/21dcdb0
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

2 years ago
Verified as fixed on MP-dev FF46(Win 7).
Postfix screencast: http://screencast.com/t/KMBStxN1U2BC
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.