Closed Bug 1236863 Opened 9 years ago Closed 9 years ago

Bring v2.5 code in apps/sync/ in line with master

Categories

(Firefox OS Graveyard :: Sync, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

RESOLVED FIXED
2.6 S5 - 1/15
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: mbdejong, Assigned: mbdejong)

References

Details

Attachments

(1 file)

Letting shared/js/sync in master diverge from the corresponding files in apps/sync in the v2.5 branch would mean splitting our attention between the diverged code bases, so let's keep them 100% identical.
Assignee: nobody → mbdejong
Blocks: fxos-sync
Target Milestone: --- → 2.6 S5 - 1/15
Comment on attachment 8704096 [details] [review]
[gaia] michielbdejong:1236863-sync-app-from-master > mozilla-b2g:v2.5

We have to see how we can run TreeHerder tests on v2.5, due to https://bugzilla.mozilla.org/show_bug.cgi?id=1235762#c6
Attachment #8704096 - Flags: review?(ferjmoreno)
Blocks: 1232276
Attachment #8704096 - Flags: review?(ferjmoreno) → review+
Depends on: 1237570
I updated the PR (script use in comments, this already includes the patch from bug 1237570) and added a second commit to make the tests pass.
Comment on attachment 8704096 [details] [review]
[gaia] michielbdejong:1236863-sync-app-from-master > mozilla-b2g:v2.5

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #8704096 - Flags: approval-gaia-v2.5?(jocheng)
[Bug caused by] (feature/regressing bug #): This contains all the fixes we made to FxSync since v2.5 was branched. To avoid diverging code bases, we would like to update the sync app in its entirety.

[User impact] if declined: Main problem would be the sync feature would not work for users with > 1000 URLs in their browser history

[Testing completed]: We ran the unit tests from apps/sharedtest/test/unit on this branch, using node v0.12.5 and npm v2.4.1. The only failing test there is an unrelated one:

1) [sharedtest-test/unit/tag_visibility_monitor_test.js] tag_visibility_monitor basics:
     Uncaught Error: Error: expected undefined to deeply equal { Object (0, 1, ...) } (app://sharedtest.gaiamobile.org/common/test/helper.js?time=1452180828929:32)
      at onerror (app://sharedtest.gaiamobile.org/common/vendor/mocha/mocha.js:4959:10)

We also tested manually using B2G-desktop from https://groups.google.com/d/msg/mozilla.dev.fxos.sync/LjpG6KwXp0c/us1IHf83BwAJ

[Risk to taking this patch] (and alternatives if risky): if we made an error copying the files (see https://github.com/mozilla-b2g/gaia/pull/33744#issuecomment-169672240) or if there was a change in apps/system that was not made in tv_apps/smart-system that we didn't think of, that could cause a problem, but we're not aware of any such risk. The code in this patch is already live for phone Foxfooders on the nightly channel.

[String changes made]: None
Comment on attachment 8704096 [details] [review]
[gaia] michielbdejong:1236863-sync-app-from-master > mozilla-b2g:v2.5

Approved for TV 2.5
Attachment #8704096 - Flags: approval-gaia-v2.5?(jocheng) → approval-gaia-v2.5+
Thank you Josh. Michiel, could you add 'a=josh' into the commit message, please?
Flags: needinfo?(mbdejong)
blocking-b2g: --- → 2.5+
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #7)
> Thank you Josh. Michiel, could you add 'a=josh' into the commit message,
> please?

done
Flags: needinfo?(mbdejong)
https://github.com/mozilla-b2g/gaia/commit/5af3f58c84caeac2091ec9e79e39aecfb41198ba
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #9)
> https://github.com/mozilla-b2g/gaia/commit/
> 5af3f58c84caeac2091ec9e79e39aecfb41198ba

and so 2.5 is fixed :)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: