Closed Bug 1236960 Opened 6 years ago Closed 5 years ago

'Undo Removing an add-on' feature prevents reinstalling a temporary addon

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: 4mr.minj, Unassigned)

References

Details

(Whiteboard: triaged)

STR:
1) install https://github.com/mdn/webextensions-examples/tree/master/notify-link-clicks as a temporary add-on in about:debugging
2) go to about:addons (in another tab) and press the remove button. Notice that 'Undo' button is visible
3) switch back to the previous tab and try to reinstall the add-on
-> reinstallation fails. A warning can be seen in the Browser Console:
> 1452011555561	addons.xpi	WARN	temporary add-on already installed:: notify-link-clicks@mozilla.org
4) switch back to the about:addons tab and reload it. Notice that 'Undo' button is gone
5) switch back to about:debugging and retry installation
-> success
This is a side effect of the rather ugly hack we used to make undoing uninstalls of restartless add-ons work correctly. We'd need to fix bug 612168 to solve this.
Depends on: 612168
This is not yet fixed since, in the scenario outlined in the summary, the temporary addon is still installed when we reach step 5 and try to reinstall.  With the fix to 612168, |oldAddon.pendingUninstall| is now true when we reach this point, so adding logic to |XPIProvider.installTemporaryAddon| to detect and handle this case is feasible.
Whiteboard: triaged
I am no longer able to reproduce this issue on Firefox 52.0a1 (2016-11-01), Firefox 51.0a2 (2016-11-01), Firefox 50.0b11 (20161027110534) and Firefox 49.0.2 (20161019084923) under Windows 10 64-bit.

   - At step 3 the add-on icon is still displayed in about:debugging (it disappears after reloading the page) and the error seems to be correct:  “1478103853848	addons.xpi	WARN	Addon with ID notify-link-clicks-i18n@mozilla.org already installed, older version will be disabled
   - At step 4, when I switch back to Add-ons Manager tab the add-on is successfully enabled. 

I suspected that this issue was fixed by Bug 1225944
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.