Test AWS Windows builder instances based off an AMI configured by current Puppet

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: markco, Assigned: grenade)

Tracking

Details

Comment hidden (empty)
(Reporter)

Comment 1

3 years ago
Method is to spin an AMI up with Puppet enabled, allow spit instances to instantiate, kill AMI, and then watch builds to ensure they are not burning builds.
Assignee: relops → mcornmesser
(Reporter)

Comment 2

3 years ago
Error from Puppetizing golden image. 
Thu Jan 07 12:53:20 -0800 2016 /Stage[main]/Runner::Service/Exec[startrunner] (err): Failed to call refresh: C:\Windows\system32\schtasks.exe /Create /XML c:\programdata\puppetagain\start-runner.xml /tn StartRunner returned 1 instead of one of [0]
Thu Jan 07 12:53:20 -0800 2016 /Stage[main]/Runner::Service/Exec[startrunner] (err): C:\Windows\system32\schtasks.exe /Create /XML c:\programdata\puppetagain\start-runner.xml /tn StartRunner returned 1 instead of one of [0]

Hopefully this is a 1 time error. I am assuming it failed because the task already existed.
(Assignee)

Comment 3

3 years ago
The following spot instances were instantiated from ami-f7d43397 between 2016-01-28 and 2016-01-29, which was a puppetised y-2008-ec2-golden instance:

i-05ff67df (y-2008-spot-118)
i-64fe66be (y-2008-spot-200)
i-57f0688d (y-2008-spot-189)
i-54f0688e (y-2008-spot-174)
i-4ffc6495 (y-2008-spot-186)
i-40fc649a (y-2008-spot-180)
i-1dfd65c7 (y-2008-spot-184)
i-c5ce561f (y-2008-spot-142)
i-94cc544e (y-2008-spot-143)
i-f6cd552c (y-2008-spot-171)
i-c7ce561d (y-2008-spot-146)
i-88cc5452 (y-2008-spot-147)
i-69cc54b3 (y-2008-spot-144)
i-2ecd55f4 (y-2008-spot-145)

They are behaving well and running successful try builds. I recommend merging https://github.com/mozilla/build-cloud-tools/pull/158 in order that future y-2008 instances continue to be based on puppetised golden amis
(Reporter)

Comment 4

3 years ago
(In reply to Mark Cornmesser [:markco] from comment #2)
> Error from Puppetizing golden image. 
> Thu Jan 07 12:53:20 -0800 2016
> /Stage[main]/Runner::Service/Exec[startrunner] (err): Failed to call
> refresh: C:\Windows\system32\schtasks.exe /Create /XML
> c:\programdata\puppetagain\start-runner.xml /tn StartRunner returned 1
> instead of one of [0]
> Thu Jan 07 12:53:20 -0800 2016
> /Stage[main]/Runner::Service/Exec[startrunner] (err):
> C:\Windows\system32\schtasks.exe /Create /XML
> c:\programdata\puppetagain\start-runner.xml /tn StartRunner returned 1
> instead of one of [0]
> 
> Hopefully this is a 1 time error. I am assuming it failed because the task
> already existed.

This was being caused by Puppet trying to recreate a task. However, the reason was the task xml file in C:\windows\system32\tasks lost the file extension portion of the file name. Not sure on what was the cause.
(Reporter)

Updated

3 years ago
Assignee: mcornmesser → rthijssen
(Assignee)

Comment 5

3 years ago
Fixed here: https://github.com/mozilla/build-cloud-tools/commit/c55c7410e5802a5d8adf4318313ce1bcff421da1
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.