Search on page (findbar) stops updating text labels when it finds after hidden <textarea> or <input>

VERIFIED DUPLICATE of bug 1174036

Status

()

defect
VERIFIED DUPLICATE of bug 1174036
3 years ago
3 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 unaffected, firefox46 unaffected, firefox47 unaffected, firefox48 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

3 years ago
>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20160104030217
STR:
1. Open attached "testcase 1", make sure only 4 <textarea>s are visible on the page
2. Open Findbar (Ctrl+F), select all text there, type "e" instead of selected text
3. Make sure the first "e" on the page is highlighted
4. Press Shift+Enter
5. Press Enter

Result:       
 After Steps 4 and 5 there's no informative text in findbar

Expectations: 
 After Step 4 the text label in findbar should say "Reached top of page, continued from bottom"
 After Step 5 the text label in findbar should say "Reached end of page, continued from top"

Notes:
 1) Actually, another text label in findbar should display the number of current found string,
    but I used the expectations above to get the regression range.
 2) It causes noticeable breakage in e10s mode: see "User Story" in bug 1174036

Regression range:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=711f08b0aa1d&tochange=37516445a0b5
Reporter

Updated

3 years ago
No longer blocks: 1174036
Reporter

Comment 1

3 years ago
To be clear: (1) this was caused by bug 916481 (see regression range)
(2) This will probably fix bug 1174036, so I marked it as blocking bug
Blocks: 1174036
Reporter

Updated

3 years ago
Summary: Search on page (findbar) breaks when it founds hidden <textarea> or <input> → Search on page (findbar) stops updating text labels when it finds after hidden <textarea> or <input>
Thanks arni!
I don't think I need to track this as it's been a regression since Firefox 29. But I am taking a look in bug 1174036.
Dolske, can you help find an assignee?
Flags: needinfo?(dolske)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(dolske)
Resolution: --- → DUPLICATE
Duplicate of bug: 1174036
(In reply to arni2033 from comment #1)
> This will probably fix bug 1174036, so I marked it as blocking bug

Thanks for spotting that.
Reporter

Comment 6

3 years ago
Fixed on:   Win7_64, Nightly 48, 32bit, ID 20160330030326

I still see minor bugs in those testcases, but nothing like bug 1174036 and bug 1236972 (this)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.