Scrubbing through a song to the end can make the scrubber stuck in fast seeking mode

RESOLVED DUPLICATE of bug 1183544

Status

Firefox OS
Gaia::Music
RESOLVED DUPLICATE of bug 1183544
3 years ago
3 years ago

People

(Reporter: Johnt, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master affected)

Details

(Whiteboard: [2.6-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8704366 [details]
logcat_20160105_1448.txt

Description:
If the user scrubs through the last song from their music library the scrubber will be stuck in fast seeking mode when attempting to play another song. 

Repro Steps:

Prereq: At least a few songs within music library. 

1) Update a Aries to 20151222120532
2) Select Music
3) Select Songs tab
4) Play and scrub through the last song (hold the fast forward scrubber about a second after the song has finished)
5) Play a track that is before the last track.

Actual:
Scrubber is stuck in fast seeking mode.

Expected:
It is expected the song will play at the default speed and not be stuck in fast seeking mode.

Environmental Variables:
Device: Aries 2.6 Kk
BuildID: 20151222120532
Gaia: f3cf488a97ecaec43369f3e3d8a7dda52be019f9
Gecko: ad16863d1d45bd3fd7906c76fa1ac1e12d24a133
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

User Impact:
User will be unable to listen to their music unless the music app is restarted.

Repro frequency: 7/10
See attached: Logcat & Video

Video: https://youtu.be/mRcWFkLbigM
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame Master and Flame 2.5
Result: Music will be stuck in fast seeking mode.

Environmental Variables:
Device: Flame 2.6 Kk Fullflash (512mb)
BuildID: 20160105030240
Gaia: 78b2bc4cad3fcf83cbbbe4aeb77079cf956972cf
Gecko: 29258f59e5456a1a518ccce6b473b50c1173477e
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0


Environmental Variables:
Device: Flame 2.5 Kk Fullflash (512mb)
BuildID: 20160105125513
Gaia: 50c5babe34fb2b055da34fdde6847aabffe73246
Gecko: d8517b54e27903b9f0a94d76470b4f8126e09eb0
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [2.6-Daily-Testing][Spark]
No-Jun, can you take a look at this please?
blocking-b2g: --- → 2.6?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(npark)
To me, this bug sounds very similiar to Bug 1183544, (or perhaps even 1226307?) Both are marked as blockers.  I'll mark it as a dup, and let me know if I am wrong.  ni?ing John for correction.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(npark) → needinfo?(jthomas)
Resolution: --- → DUPLICATE
Duplicate of bug: 1183544

Updated

3 years ago
blocking-b2g: 2.6? → ---
(Reporter)

Comment 4

3 years ago
(In reply to No-Jun Park [:njpark] from comment #3)
> To me, this bug sounds very similiar to Bug 1183544, (or perhaps even
> 1226307?) Both are marked as blockers.  I'll mark it as a dup, and let me
> know if I am wrong.  ni?ing John for correction.
> 
> *** This bug has been marked as a duplicate of bug 1183544 ***

The closest bug I can find in relation to this is Bug 1231234 although it appears to be similar to Bug 1183544 as well. Not sure if Bug 1226307 has any relation to it.
(Reporter)

Updated

3 years ago
Flags: needinfo?(jthomas)
You need to log in before you can comment on or make changes to this bug.