Closed Bug 1237223 Opened 6 years ago Closed 6 years ago

[TV] FxOS TV Metrics - The usage of the preview windows and webistes from Marketplace are not recorded by metrics

Categories

(Firefox OS Graveyard :: Gaia::TV::System, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- verified
b2g-master --- verified

People

(Reporter: lchang, Assigned: lchang)

References

Details

(Whiteboard: [ft:conndevices])

Attachments

(2 files, 1 obsolete file)

For now, App Usage Metrics doesn't record the app usage of the preview window, which is triggered by Marketplace.
blocking-b2g: --- → 2.5?
We have two questions:

1) what is considered "preview"? -- When the item is highlighted in Marketplace and shown in the top area of the Marketplace UI? or when it is accessed by the user but not pinned?

2) This bug is specifically talking about App Usage metric in Firefox OS, but there is also the question of whether we need telemetry at the website/app level from *within* Marketplace (which we generally record via firing UA events from the UI, and then report on from Google Analytics).
Flags: needinfo?(lchang)
Priority: -- → P3
since i was on bug 1237225, let me take a stab at answering this but let's hear it from Luke as well

what we really want to understand is how frequent the apps (in the TV case, those hosted websites) are being used, similar to the idea of our mobile and mobile marketplace. It's just that apps on mobile can be packaged apps and for TV, it's just all hosted 

1) i would say it is when it is accessed by the user but not pinned, though if we feel this is too much, we can discuss about making it record the app usage only when the TV websites are installed/pinned 

2) the intention was simply to leverage what we are doing on mobile but if there are better ways to do so, open to it.
(In reply to David Durst [:ddurst] from comment #1)
> 1) what is considered "preview"? -- When the item is highlighted in
> Marketplace and shown in the top area of the Marketplace UI? or when it is
> accessed by the user but not pinned?

It's a TV specific feature [1]. The app will be launched immediately in a preview window on top of the Marketplace app (like a popup window) when the user clicks an app icon in Marketplace. Since users can really interact with that app, we'd like to treat it as a normal app and track its usage as well.

[1] UX Spec: http://bit.ly/1NwrKGk


> 2) This bug is specifically talking about App Usage metric in Firefox OS,
> but there is also the question of whether we need telemetry at the
> website/app level from *within* Marketplace (which we generally record via
> firing UA events from the UI, and then report on from Google Analytics).

Yes, it's a good way to track actions that users do within Marketplace app. However, what we intend to collect is about other apps so I'm afraid Google Analytics doesn't suit this case.

But it's still useful if we want to know how users use Marketplace app itself in the future.
Flags: needinfo?(lchang)
Assignee: nobody → lchang
Status: NEW → ASSIGNED
Blocks: TV_P1
blocking-b2g: 2.5? → 2.5+
Two things here:

a. That "preview" happens on hover -- so basically, when I click across a row of apps, each gets "previewed." Is this what we would purport to track? That doesn't seem useful.

b. If we want to track things in the pre-selected state, it sounds like we should track pinning and/or opening instead. But do we want to distinguish between pinning here, in Marketplace, vs pinning elsewhere in the TV?
Flags: needinfo?(lchang)
Flags: needinfo?(jcheng)
(In reply to David Durst [:ddurst] from comment #4)
> a. That "preview" happens on hover -- so basically, when I click across a
> row of apps, each gets "previewed." Is this what we would purport to track?
> That doesn't seem useful.

Actually, "preview" happens on click.

The "preview" is *not* the screenshot shown in the Marketplace but the *popupwindow* launched outside of the Marketplace. You can simply treat that as a "auto-install, launch and auto-uninstall" flow.

> b. If we want to track things in the pre-selected state, it sounds like we
> should track pinning and/or opening instead. But do we want to distinguish
> between pinning here, in Marketplace, vs pinning elsewhere in the TV?

So, we do *not* intend to track things in the pre-selected state but to track an app is launching as usual.
Flags: needinfo?(lchang)
Flags: needinfo?(jcheng)
Comment on attachment 8712995 [details] [review]
[gaia] luke-chang:1237223_tv_metrics_track_preview > mozilla-b2g:master

Hi Rex,

Would you mind taking a look? Thanks.
Attachment #8712995 - Flags: review?(rexboy)
Forgot to mention: This bug also addressed the issue in bug 1237225 since they're related problems.
Duplicate of this bug: 1237225
Summary: [TV] FxOS TV Metrics - The usage of the preview window from Marketplace is not recorded by metrics → [TV] FxOS TV Metrics - The usage of the preview windows and webistes from Marketplace are not recorded by metrics
Comment on attachment 8712995 [details] [review]
[gaia] luke-chang:1237223_tv_metrics_track_preview > mozilla-b2g:master

Looks ok to me.
Attachment #8712995 - Flags: review?(rexboy) → review+
Whiteboard: [ft:conndevices]
Got it, thanks. Removing from Marketplace tree.
No longer blocks: TV_Marketplace_2.5
landed on master: https://github.com/mozilla-b2g/gaia/commit/50cbf9056b882099e1e6b6826ac96460ca5aea81
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8712995 [details] [review]
[gaia] luke-chang:1237223_tv_metrics_track_preview > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): TV Metrics feature.
[User impact] if declined: feature isn't complete.
[Testing completed]: yes.
[Risk to taking this patch] (and alternatives if risky): low.
[String changes made]: N/A
Attachment #8712995 - Flags: approval-gaia-v2.5?
Comment on attachment 8712995 [details] [review]
[gaia] luke-chang:1237223_tv_metrics_track_preview > mozilla-b2g:master

Approve for TV 2.5
Attachment #8712995 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Found a minor bug. Reverted and will re-landed it as soon as possible.

revert: https://github.com/mozilla-b2g/gaia/commit/a0e2f0304b7051680ad834c383489df78098f33c
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #8712995 - Flags: approval-gaia-v2.5+
Attachment #8714272 - Attachment is obsolete: true
Comment on attachment 8714275 [details] [review]
[gaia] luke-chang:1237223_tv_metrics_track_preview > mozilla-b2g:master

Carry over Rex's r+
Attachment #8714275 - Flags: review+
re-landed on master: https://github.com/mozilla-b2g/gaia/commit/6175390934abf7916ab0e1adad231c2db27b669a
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Comment on attachment 8714275 [details] [review]
[gaia] luke-chang:1237223_tv_metrics_track_preview > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): TV Metrics feature.
[User impact] if declined: feature isn't complete.
[Testing completed]: yes.
[Risk to taking this patch] (and alternatives if risky): low.
[String changes made]: N/A
Attachment #8714275 - Flags: approval-gaia-v2.5?
Comment on attachment 8714275 [details] [review]
[gaia] luke-chang:1237223_tv_metrics_track_preview > mozilla-b2g:master

Approve for TV 2.5
Attachment #8714275 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Verify this issue on both v2.5 and v2.6 latest build and the result is PASS.
The usage of the preview windows and webistes from Marketplace can be recorded by metrics properly.

[Build Info]
2.6 TV Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/f41e046a5c6032d9ce281fdb96256be7fc9b0c0f
gecko:
https://hg.mozilla.org/mozilla-central/rev/2b5237c178ea02133a777396c24dd2b713f2b8ee

2.5 TV Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/71952d4b5417796380ddab274c5566a8eced2f8b
gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/0b279b0579ae5656e3df34d522af06800e0a03bf
mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/9d519d3bedacb7f5ce467f4c6bef7ff55ff3b0f3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.