TEST-UNEXPECTED-ERROR | test_places.py TestPlaces.test_plugins | NameError: global name 'errors' is not defined

RESOLVED FIXED in Firefox 43

Status

Testing
Firefox UI Tests
P1
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

({intermittent-failure})

45 Branch
mozilla46
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox43 fixed, firefox44 fixed, firefox45 fixed, firefox46 fixed, firefox-esr38 unaffected)

Details

Attachments

(1 attachment)

52 bytes, text/x-github-pull-request
maja_zf
: review+
Details | Review | Splinter Review
(Assignee)

Description

2 years ago
Something changed in Firefox Nightly which caused a hidden problem be raised:

 06:55:58     INFO - Traceback (most recent call last):
 06:55:58     INFO -   File "/home/mozauto/jenkins/workspace/mozilla-central_functional/build/venv/local/lib/python2.7/site-packages/marionette/marionette_test.py", line 344, in run
 06:55:58     INFO -     testMethod()
 06:55:58     INFO -   File "/home/mozauto/jenkins/workspace/mozilla-central_functional/build/venv/local/lib/python2.7/site-packages/firefox_puppeteer/tests/test_places.py", line 66, in test_bookmarks
 06:55:58     INFO -     self.places.restore_default_bookmarks()
 06:55:58     INFO -   File "/home/mozauto/jenkins/workspace/mozilla-central_functional/build/venv/local/lib/python2.7/site-packages/firefox_puppeteer/api/places.py", line 105, in restore_default_bookmarks
 06:55:58     INFO -     raise errors.MarionetteException("Restore Default Bookmarks failed")

The issue is here:

https://github.com/mozilla/firefox-ui-tests/blob/mozilla-central/firefox_puppeteer/api/places.py#L8
https://github.com/mozilla/firefox-ui-tests/blob/mozilla-central/firefox_puppeteer/api/places.py#L105

We import the error classes directly but when raising an exception we use the errors module as prefix.
(Assignee)

Comment 1

2 years ago
Created attachment 8704687 [details] [review]
Github PR
Attachment #8704687 - Flags: review?(mjzffr)
Attachment #8704687 - Flags: review?(mjzffr) → review+
(Assignee)

Updated

2 years ago
Blocks: 1237322
(Assignee)

Comment 2

2 years ago
Merged PR to mozilla-central branch as:
https://github.com/mozilla/firefox-ui-tests/commit/b4af4d8dcc84c9d5d43d44ff25671d040920cbb1

It's not a bustage on other branches yet, so I will backport this later today or tomorrow.
(Assignee)

Updated

2 years ago
status-firefox46: affected → fixed
Target Milestone: --- → Firefox 46
(Assignee)

Comment 3

2 years ago
I also updated the python_packages branch for this change by rebasing it against mozilla-central.
(Assignee)

Updated

2 years ago
Keywords: intermittent-failure
Product: Mozilla QA → Testing
(Assignee)

Comment 4

2 years ago
Backports for other affected branches:

https://github.com/mozilla/firefox-ui-tests/commit/6570a995800dcbca56abc8be449614ab837355dd (aurora)
https://github.com/mozilla/firefox-ui-tests/commit/58cf08105f8e10bca1d51a2ad3c69a929cdd32c8 (beta)
https://github.com/mozilla/firefox-ui-tests/commit/fe145ef9d823865efcd2610ac92325493ed6d645 (release)
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox43: affected → fixed
status-firefox44: affected → fixed
status-firefox45: affected → fixed
Resolution: --- → FIXED

Comment 5

2 years ago
37 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-central: 37

Platform breakdown:
* windows8-64: 5
* windows7-64: 5
* windowsxp: 3
* windows8-32: 3
* windows7-32: 3
* osx-10-9: 3
* osx-10-6: 3
* osx-10-11: 3
* osx-10-10: 3
* linux64: 3
* linux32: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1237295&startday=2016-01-04&endday=2016-01-10&tree=all
You need to log in before you can comment on or make changes to this bug.