tabbed browsing pref label specifies wrong modifier key (control for command)

VERIFIED FIXED

Status

SeaMonkey
Tabbed Browser
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: Javier Morales, Assigned: jag (Peter Annema))

Tracking

({polish})

Trunk
PowerPC
Mac OS X
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020411

turning on control-click for opening link in a new tab or for opening bookmark
in a new tab does nothing on MacOS X or 9 since control-click will open a new
browser window

Reproducible: Always
Steps to Reproduce:
1.Turn prefs for control-clicking on
2.control-click on any link or bookmark
3.

Actual Results:  I get standard "right-click" menu

Expected Results:  not sure, maybe opening link/boomarks in a new tab should be
triggered by different combo on the mac. command-option click would be pretty
mac-like. =>

Comment 1

16 years ago
Confirmed. Mac Mozilla builds should offer option-clicking, perhaps, as an
alternative to this, since control-clicking is system-reserved.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Sending to Tabbed Browser.
Assignee: asa → jaggernaut
Component: Browser-General → Tabbed Browser
QA Contact: doron → sairuh
Option-clicking is save to file.  Command clicking opens in a new tab.  

I think the help text just needs to be updated.
Specifically, under:

Mozilla...Preferences...Navigator...Tabbed Browsing...Open tabs instead of
windows for,

   Middle-click or control-click of links in a Web page

needs to be:

   Command-click of links in a web page

if the flower symbol can be added, great; most mac users don't know what the
command key is.

Even if middle click actually works, it's not important to say it because so few
mac users have three-buttoned mouses.

Changing summary:
old - control-click for tabbed browsing conflicts with control-click for
contextual menu
new - tabbed browsing pref label specifies wrong modifier key (control for command)
adding keyword polish
Keywords: polish
Summary: control-click for tabbed browsing conflicts with control-click for contextual menu → tabbed browsing pref label specifies wrong modifier key (control for command)

Comment 5

16 years ago
*** Bug 164677 has been marked as a duplicate of this bug. ***
QA Contact: sairuh → pmac

Comment 6

15 years ago
this was fixed by bug 106398.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Looks like this went in 2003.01.28.03

I can verify that the labels are correct in 1.4.  Looks good.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.