Navigation toolbar is disabled and remains disabled if browser is launched without cellular data

RESOLVED FIXED

Status

()

Firefox for iOS
Browser
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aaronmt, Assigned: bnicholson)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios2.0+)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Currently the navigation toolbar at the bottom of the browser is disabled and will remain disabled should a user run into the prompt to re-enable cellular data for Firefox.


* Launch browser with cellular data disabled in Firefox (Settings). Assume no WiFi connection on the device

* Re-enable cellular data, swap back to Firefox

* See toolbar disabled, go to any site, see toolbar still disabled

Work-around: rotate the device back and forth to re-draw the toolbar with proper state

Seems like we have a silly logic problem.
Rank: 1
tracking-fxios: ? → 2.0+
Component: General → Browser
Hardware: Other → All
(Assignee)

Comment 1

2 years ago
It's possible that disabling cellular data in Settings also blocks resources being served on our local web server, which I think would prevent our session restore callback from being triggered. If that's the case, I'm not too concerned since I'm skeptical we can actually hit this in real-world scenarios.
(Assignee)

Updated

2 years ago
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 years ago
I can't reproduce this in the simulator or on my iPod, so this must be related to this specific setting (as opposed to simply lack of a data connection). AaronMT confirmed that he only sees blank pages (no error pages), which supports the hypothesis in comment 1.

I can, however, replicate this behavior if I simply prevent the web server from starting in my local build. I think the fix will be to make sure the browser toolbar state is updated for each page load (though I thought we'd be doing that already).
(Assignee)

Comment 3

2 years ago
Created attachment 8710189 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/1461

While I can test this PR by manually disabling the web server, I can't actually verify that this fixes the STR since I can't follow them without an iPhone. Aaron/Steph, would appreciate if you can try!

It seems that disabling cellular data prevents our local web server from working, so even with this fix, it's worth noting that there will be other annoyances with that setting enabled. In particular, session restore won't work, and users can't access saved offline reader pages.
Attachment #8710189 - Flags: review?(sleroux)
Comment on attachment 8710189 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/1461

LGTM
Attachment #8710189 - Flags: review?(sleroux) → review+
(Assignee)

Comment 5

2 years ago
https://github.com/mozilla/firefox-ios/commit/628591dae57aca7bd98f2c6f7f01befefca72ba5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.