const in for...of statement doesn't work

RESOLVED DUPLICATE of bug 1101653

Status

()

defect
RESOLVED DUPLICATE of bug 1101653
3 years ago
3 years ago

People

(Reporter: klimashkin, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Steps to reproduce:

for (const a in [1,2,3]) { console.log(a) }


Actual results:

SyntaxError: invalid for/in left-hand side


Expected results:

Log:
1,
2,
3

http://www.ecma-international.org/ecma-262/6.0/index.html#sec-for-in-and-for-of-statements-static-semantics-boundnames
(Reporter)

Updated

3 years ago
Severity: normal → critical
OS: Unspecified → All
Hardware: Unspecified → All

Updated

3 years ago
Severity: critical → normal
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1101653
You need to log in before you can comment on or make changes to this bug.