test_settings_device_info.py - AssertionError: u'\u2068864332020022598\u2069' != u'864332020022598' - \u2068864332020022598\u2069 ? - - + 864332020022598

RESOLVED DUPLICATE of bug 1231988

Status

RESOLVED DUPLICATE of bug 1231988
3 years ago
3 years ago

People

(Reporter: JMercado, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Description: Test case fails with "AssertionError: u'\u2068864332020022598\u2069' != u'864332020022598' - \u2068864332020022598\u2069 ? - - + 864332020022598"

Steps:
1. Update a flame device to 20160106060008
2. Run this test case http://lxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_device_info.py

Actual result:
AssertionError: u'\u2068864332020555159\u2069' != u'864332020555159'
- \u2068864332020555159\u2069
? - -
+ 864332020555159

Expected result:
Test completes successfully.

Repro Rate: Reproduced via Jenkins adhoc (0/5 passing)
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc.bitbar/395/HTML_Report/

Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@2/.env/lib/python2.7/site-packages/marionette_client-2.0.0-py2.7.egg/marionette/marionette_test.py", line 344, in run
testMethod()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@2/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_device_info.py", line 34, in test_that_device_info_is_populated
self.assertEqual(getattr(more_info, 'imei{}'.format(i)), expected_imei)
AssertionError: u'\u2068864332020555159\u2069' != u'864332020555159'
- \u2068864332020555159\u2069
? - -
+ 864332020555159
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1231988
You need to log in before you can comment on or make changes to this bug.