middle-click (open URL in new window) doesn't

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Cameron Simpson, Assigned: Peter Trudelle)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Netscape/4.78 [en] (X11; U; Linux 2.4.16-pre1 i686; Nav)
BuildID:    2002020415

BTW, ignore the user-agent above - I'm using Mozilla 0.9.8. I've
hacked the User-Agent to try to convince my bank to deal with me.
This bug was still a bug before I modified the user-Agent field.

AFAIK, this is the only web page on the planet which does this,
but it's completely consistent. Maybe it's a style sheet thing.

Anyway, with most "news" web pages I middle-click to launch interesting
headlines in their own window. In this page this is a no-op - very strange.

This behaviour obtained in Mozilla 0.9.7 as well as 0.9.8. Unsure
about earlier versions.

The URLs are all normal - no javascript involved.
Left-click (open URL in current window) works fine.


Reproducible: Always
Steps to Reproduce:
1. Visit web page.
2. Middle click on first headline in the main (middle) section.
3. Observe no new window.

Expected Results:  A new window with the desired story should appear.
I'll confirm new based on behavior.   I can't tell if some js magic
is happening or not, but the described behavior does occur.

Changing OS to all.  Replicated on 2002012903 win32.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

17 years ago
WORKSFORME: Linux (2.4.4), PC, BuildID 2002022108

has it been fixed since 2002020415?

Comment 3

17 years ago
Works for middle click opening link in a new window or a new tab.

Comment 4

17 years ago
WORKSFORME: Win2k, BuildID 2002022103

Perhaps the website is fixed?  Can someone confirm this again on a recent build?

-------------------------------------

This appears to be related to several existing "bugs":
  Bug 70135
  Bug 40535
  Bug 14716
These have all been marked Future.  Perhaps this should be marked RFE and Future
as well, if it still indeed exists?
(Reporter)

Comment 5

17 years ago
The web site is indeed "fixed". This means the bug is probably still in
Mozilla's code. So you can't really mark this as an RFE - it's a bug. But you
could defer it for the future unless another such site surfaces.
- Cameron

Comment 6

17 years ago
->apps
Assignee: asa → trudelle
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh
(Assignee)

Comment 7

17 years ago
resolving as wfm, unless anyone knows of specific changes made to the web page
that 'fixed' this.  If there really is a generic problem, we should create
another bug that describes it, but since this just describes a specific problem
which no longer exists, it is wfm.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → Future
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.