FF43 Partner repack changes for Yahoo - New builds needed with latest version of toolbar

RESOLVED FIXED

Status

Release Engineering
Releases: Custom Builds
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Sneha Datla, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Hi,

We made a recent change to the toolbar code to address the issue where toolbar's AMO signature was getting invalidated. Our PR for this was merged. Can we get new Yahoo custom builds with this change?

Thanks,
Sneha
43.0.4 builds are already available on the partner portal.  Do those not have the latest config updates?
Status: UNCONFIRMED → NEW
Ever confirmed: true
I merged the yahoo changes @ 2:24PST Jan 6, they probably made it into the new builds but it should be verified.

Sneha, let us know if the new builds are ok.
Flags: needinfo?(sdat27)
(Reporter)

Comment 3

2 years ago
Yes the new 43.0.4 builds have the latest changes. However, the toolbar is disabled on the Mac builds but it is fine in the Windows builds. Any idea?
Flags: needinfo?(sdat27)
Sneha, is it disabled or just hidden?  ie. can you make it appear via the View->Toolbars menu?  Was it visible in prior versions?
Flags: needinfo?(sdat27)
(Reporter)

Comment 5

2 years ago
Created attachment 8705342 [details]
Toolbar is disabled on Mac build

It's disabled and will show up only if xpinstall.signatures.required pref is set to false. It was fine in FF42 but not with FF43.

Windows builds are fine. The issue is only on the Mac builds
Flags: needinfo?(sdat27)
I just downloaded the addon from AMO and diff'd against what is in github.  One file, components/nsYahooPluginManager.js, is different (might even be only line endings) which would cause a signing failure.  That failure should be happening on all platforms but am only testing on osx right now.  If you can fix this issue and create a new pull request, then we can request a respin.
Flags: needinfo?(sdat27)
jorge, mconnor,

would line ending differences cause a signing failure on osx but not on windows?  If that is the case, seems like a bug in the signing check.
Flags: needinfo?(mconnor)
Flags: needinfo?(jorge)
(Reporter)

Comment 8

2 years ago
Yes there are ^M characters at the end of the lines in that file. I will remove the ^M characters in that file and I'll create a PR for that once it's fixed

Thanks!
Flags: needinfo?(sdat27)
If the file is being modified after it was signed, I wouldn't consider that a signature bug. We can't account for all possible line ending formats and/or file encodings.
Flags: needinfo?(jorge)
(In reply to Jorge Villalobos [:jorgev] from comment #9)
> If the file is being modified after it was signed, I wouldn't consider that
> a signature bug. We can't account for all possible line ending formats
> and/or file encodings.

Jorge, the same file in the repack, signing passes on windows (I'm assuming Sneha tested correctly), fails on osx (I verified osx).  My question is more around, should that be happening, if so why?
It shouldn't be happening if the same files are just being moved/copied. It can be that the files are being modified somehow, or one of the folders containing those files was opened by the user using Finder/File Manager, which sometimes generates hidden files in those folders.
@coop, could we respin yahoo 43.0.4?
Flags: needinfo?(mconnor) → needinfo?(coop)
(Assignee)

Comment 13

2 years ago
(In reply to Shane Caraveo (:mixedpuppy) from comment #12)
> @coop, could we respin yahoo 43.0.4?

Yep, I'll kick that off now.
Assignee: nobody → coop
Status: NEW → ASSIGNED
Flags: needinfo?(coop)
(Reporter)

Comment 14

2 years ago
The latest builds are working fine now.

Thanks!
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.