www.winradio.net.au pages incorrectly uses sgml comments

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Catalin Ionescu, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

Some pages in the site are displayed only in part. Both IE and Opera show them
completely so I think an error in the page sources is quite unlikely.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.winradio.net.au
2. Open the Product->Software or the Company page
3. Compare to what IE displays on those pages

Comment 1

17 years ago
A whole table full of information is not shown, which is strange.

Comment 2

17 years ago
confirming, http://www.winradio.net.au/home/software.htm cotains alot of invalid
comment tags <!--- ---> which should be <!-- -->
removing those makes mozilla render the page correctly
(Reporter)

Comment 3

17 years ago
This like saying that, for example, /** and **/ can not be safely used in C
instead of "classical" /* and */. It surely sounds a little bit silly to me! The
standard says that the comments must be delimited by '<!--' and '-->', not '<!--
' and ' -->'.

So I consider the pages with problems are Ok! They respect the HTML standard and
they should be properly displayed by Mozilla with no change at all!
(Reporter)

Comment 5

17 years ago
Than why all other browsers properly display the page?

As a C/C++ programmer, the examples gave on the W3C page are irrelevant. They
say that comments are delimited by "<!" immediately followed by "--". There is
nothing to say that there should be "-- ". Also the comment closing sequence
seems correct as there is no strange situation like the ones they suggest. You
have the first pair giving "--" after the comment text and, after an extra '-'
that is completely insignificant, the '>' that closes the comment.

As I'm used to technical specifications and wrongly explained situations, the
W3C standard practically says that the comments in those web-pages are Ok. And
I've taken step by step the W3C description on the incriminated comments!

Comment 6

17 years ago
this is a dupe of 115899

Comment 7

17 years ago
hell, im having a very bad day, i mean its a dupe of Bug 103529

Comment 8

17 years ago
we don't resolve evangelism bugs as duplicates unless they're the for the same 
problem at the same site.
Assignee: asa → momoi
Component: Browser-General → English: Non-US
Product: Browser → Tech Evangelism
QA Contact: doronr → jonrubin
Summary: pages incompletely displayed → www.winradio.net.au pages incorrectly uses sgml comments
Version: other → unspecified

Comment 9

17 years ago
Invalid HTML according to validator.w3.org.  Confirming on 2002022203/WinXP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All

Comment 10

16 years ago
code has been cleaned, WFM

Comment 11

16 years ago
resolving as FIXED since html code has been corrected
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 12

15 years ago
Mass reassigning English-Other bugs to general default assignees.
Assignee: momoi → english-other
QA Contact: jonrubin → english-other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.