Number is shown as unknown in settings

RESOLVED WONTFIX
(NeedInfo from)

Status

RESOLVED WONTFIX
3 years ago
a month ago

People

(Reporter: VP7, Unassigned, NeedInfo)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bzlite])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

I  went to setting -> device information

there it shows as number unknown. I have Sim in my phone.

Mine is India Sim  and number is +91-9443942201

it is reproducable in flame also.
(Reporter)

Comment 1

3 years ago
Created attachment 8705012 [details]
2016-01-07-10-24-02.png
(In reply to Viswaprasath [:VP7] from comment #0)
> User-Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
> 
> I  went to setting -> device information
> 
> there it shows as number unknown. I have Sim in my phone.
> 
> Mine is India Sim  and number is +91-9443942201
> 
> it is reproducable in flame also.

In Flame is it reproducible in both SIM slots?
(Reporter)

Comment 3

3 years ago
Another contributor (Artem Polivanchuk) in Foxfooding group.mentioned it is in sim1

Comment 4

3 years ago
Hi,

I have two sim cards - corporate and my own, prepaid.
When I used the corporate one on the SIM1 slot on Flame, I noticed that phone number in the Divice information of Settings menu displayed as "unknown".

Currently I use that SIM card on Z3C and its number displayed as "unknown" also.
But today I put my second prepaid sim card into the SIM1 slot on Flame and the number has been identified and displayed properly.
Unfortunately there is no way to test this card on Z3C because of the SIM card type.
So, in my opinion we have to do an extra tests to confirm the issue.
I can reproduce this on my Z3C. Number is displayed as "unknown".
Build ID: 20151230201227
Thanks for the help Marcia.
QA Whiteboard: [foxfood-triage]
Flags: needinfo?(mozillamarcia.knous)
Can you verify that the SIM is not locked and relaunch the settings app?
The number might not show if the SIM is locked.  I've ran into this issue before.
Flags: needinfo?(mozillamarcia.knous) → needinfo?(SHIHAN.VISWA)

Comment 8

2 years ago
fxos is dead
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 9

7 months ago
Seems no fix will be provided now.
(Reporter)

Comment 10

a month ago
Removing more info needed.
You need to log in before you can comment on or make changes to this bug.