If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Dialer]The number '1' will disappear after a short time when long tap '1' in emergency call.

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: zouyi(Leave from Mozilla), Assigned: gsvelto)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8705051 [details]
logcat_1647.txt

[1.Description]:
[Dialer][Aries master&v2.5][Flame master&v2.5]Long tap '1', the number '1' will disappear after a short time in emergency call.
See attchment:logcat_1647.txt&Aries_kk v2.5.3gp
Found time: 16:47

[2.Testing Steps]: 
Preconditon: The passcode is enabled.
1. Tap power button to wake up the device.
2. Slide to the right.
3. Go to emergency call view.
4. Long tap '1', observe the view.

[3.Expected Result]: 
4. The number '1' should exist all the time.

[4.Actual Result]: 
4. The number '1' will disappear after a short time.

[5.Reproduction build]: 

Device: Aries KK master(Affected)
Build ID               20160106144831
Gaia Revision          81c021654c657f6995e5e70ef02ee067d4bfedbd
Gaia Date              2016-01-06 01:38:56
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1ec3a3ff68f2d1a54e6ed33e926c28fee286bdf1
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20160106.150839
Firmware Date          Wed Jan  6 15:08:47 UTC 2016
Bootloader             s1

Device: Flame KK v2.5 512mb(Affected) 
Build ID               20160105125513
Gaia Revision          50c5babe34fb2b055da34fdde6847aabffe73246
Gaia Date              2016-01-05 10:22:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d8517b54e27903b9f0a94d76470b4f8126e09eb0
Gecko Version          44.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20160105.120745
Firmware Date          Tue Jan  5 12:07:54 UTC 2016
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5(Affected)
Build ID               20160105132122
Gaia Revision          50c5babe34fb2b055da34fdde6847aabffe73246
Gaia Date              2016-01-05 10:22:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d8517b54e27903b9f0a94d76470b4f8126e09eb0
Gecko Version          44.0
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20160105.125332
Firmware Date          Tue Jan  5 12:53:40 UTC 2016
Bootloader             s1

Device: Flame KK master 512mb(Affected)
Build ID               20160106150203
Gaia Revision          81c021654c657f6995e5e70ef02ee067d4bfedbd
Gaia Date              2016-01-06 01:38:56
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1ec3a3ff68f2d1a54e6ed33e926c28fee286bdf1
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20160106.194329
Firmware Date          Wed Jan  6 19:43:42 EST 2016
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

2 years ago
Created attachment 8705054 [details]
Aries_kk v2.5.3gp
(Reporter)

Updated

2 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
(Assignee)

Comment 2

2 years ago
Confirmed, this means that the voicemail-detection code (long-tap 1) is active in the emergency call dialer, but it shouldn't.
Nom to 2.6 as per previous comment #2
blocking-b2g: --- → 2.6?

Comment 4

2 years ago
Created attachment 8705186 [details] [review]
[gaia] gabrielesvelto:bug-1237548-emergency-call-disable-voicemail > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
(Assignee)

Comment 5

2 years ago
Comment on attachment 8705186 [details] [review]
[gaia] gabrielesvelto:bug-1237548-emergency-call-disable-voicemail > mozilla-b2g:master

Quick fix, I've taken the liberty of cleaning up the unit-tests related to touch start/stop/move events since I were at it.
Attachment #8705186 - Flags: review?(thills)
Comment on attachment 8705186 [details] [review]
[gaia] gabrielesvelto:bug-1237548-emergency-call-disable-voicemail > mozilla-b2g:master

Hi Gabriele,

Looks good to me.

Thanks,

-tamara
Attachment #8705186 - Flags: review?(thills) → review+
blocking-b2g: 2.6? → 2.6+
(Assignee)

Comment 7

2 years ago
Thanks for the review Tamara, I had to change a unit-test which was broken before landing but the change was so small I didn't think it was worth another review. Merged to gaia/master ebbddcec92a30f3110ad863ac909f52b041ef9a5

https://github.com/mozilla-b2g/gaia/commit/ebbddcec92a30f3110ad863ac909f52b041ef9a5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

2 years ago
This bug has been verified as pass on latest build of Flame KK matser 512mb and Aries KK master by the STR in comment 0.

Actual results: The number '1' exists all the time in emergency call.

See attachment: verified_Aries_kk master.3gp

Reproduce rate: 0/10

Device: Flame KK master 512mb(Pass)
Build ID               20160113184730
Gaia Revision          a38728b0641627dcd47a6f21b51fccf6ba0af58c
Gaia Date              2016-01-12 17:58:29
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ad1f85f172b7302bef0fa9780df8e2b962780ac6
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20160113.172753
Firmware Date          Wed Jan 13 17:28:05 EST 2016
Firmware Version        V18D V4
Bootloader             L1TC000118D0 

Device: Aries KK master(Pass)
Build ID               20160113183425
Gaia Revision          a38728b0641627dcd47a6f21b51fccf6ba0af58c
Gaia Date              2016-01-12 17:58:29
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ad1f85f172b7302bef0fa9780df8e2b962780ac6
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20160113.190400
Firmware Date          Wed Jan 13 19:04:08 UTC 2016
Bootloader             s1
(Reporter)

Updated

2 years ago
QA Whiteboard: [MGSEI-Triage+]
status-b2g-master: affected → verified
(Reporter)

Comment 9

2 years ago
Created attachment 8707774 [details]
verified_Aries_kk master.3gp
blocking-b2g: 2.6+ → ---
You need to log in before you can comment on or make changes to this bug.