Launching a window with target '_samescope' no longer works

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: cwiiis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
STR:

1- Pin a site
2- Press home key
3- Launch pinned site

Expected:

Step 3 raises the window that you pinned in step 1.

Actual:

Step 3 launches a new window.
Whiteboard: [systemsfe]
Keywords: qawanted
Naoki, can we have some QA help here?
Flags: needinfo?(nhirata.bugzilla)
blocking-b2g: 2.6? → 2.6+
I'm not seeing this issue occur with pinned sites.  Following the steps listed in comment 0 opens the same window.  However when performing the steps with a pinned page instead of site this issue occurs on the latest Aries 2.6, Flame 2.6 and Flame 2.5 builds.  

I checked an Aries central build from the 7th and saw these same results.

Actual Results: A new window is opened instead of the already opened window when selecting a pinned page on the homescreen.

Environmental Variables:
Device: Aries 2.6
BuildID: 20160114140113
Gaia: 2d6c11a1e82bd9f9b7491863c8d1ea4a14aea69f
Gecko: 27eb5e90eeee2e6a1ffe61c368c294d3de51b797
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Environmental Variables:
Device: Aries 2.6
BuildID: 20160107105120
Gaia: 676237f80cf72182500356fabc49365d3471c0e6
Gecko: e0bcd16e1d4b99ba3e542149d0d41e0f60c54b5c
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Environmental Variables:
Device: Flame 2.6
BuildID: 20160114030239
Gaia: 2d6c11a1e82bd9f9b7491863c8d1ea4a14aea69f
Gecko: 6fa2ab99f52feb1b6ead5581b8f5d398546a55a5
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20160114120948
Gaia: 1dec9c2fba119aabcc82c95225dbef24de148323
Gecko: 1faa9ae08705af5e8821b23ab9fe235beb021883
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

As pin the web is new to 2.5 this would indicate this is NOT a regression.  Chris please verify if you were seeing this with pinned sites or pinned pages as that may mean I just cannot reproduce your issue and what I've seen here should be written seprately.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted, regression, regressionwindow-wanted
Looks like Q Analyst has taken care of this request.  I apologize for the delay in my response.
Flags: needinfo?(nhirata.bugzilla)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
blocking-b2g: 2.6+ → ---
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.