TEST-UNEXPECTED-FAIL | test_favicon_in_autocomplete.py TestFaviconInAutocomplete.test_favicon_in_autocomplete | AssertionError: 'mozilla_favicon.ico' not found in u'chrome://mozapps/skin/places/defaultFavicon.png'

RESOLVED FIXED

Status

Testing
Firefox UI Tests
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

New regression on mozilla-central

 05:54:17     INFO - TEST-UNEXPECTED-FAIL | test_favicon_in_autocomplete.py TestFaviconInAutocomplete.test_favicon_in_autocomplete | AssertionError: 'mozilla_favicon.ico' not found in u'chrome://mozapps/skin/places/defaultFavicon.png'
 05:54:17     INFO - Traceback (most recent call last):
 05:54:17     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-central_functional/build/venv/lib/python2.7/site-packages/marionette/marionette_test.py", line 344, in run
 05:54:17     INFO -     testMethod()
 05:54:17     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-central_functional/build/venv/lib/python2.7/site-packages/firefox_ui_harness/decorators.py", line 13, in wrapper
 05:54:17     INFO -     return target(self, *args, **kwargs)
 05:54:17     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-central_functional/build/venv/lib/python2.7/site-packages/firefox_ui_tests/functional/locationbar/test_favicon_in_autocomplete.py", line 58, in test_favicon_in_autocomplete
 05:54:17     INFO -     self.assertIn(self.test_favicon, result_icon)
Pushlog should be:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9d6ffc7a08b6&tochange=e0bcd16e1d4b

There is nothing which directly gives my attention. Will have to use mozregression later to figure it out.
This problem actually only occurs for the test package! So looks like I missed to add this specific favicon.
https://github.com/mozilla/firefox-ui-tests/blob/mozilla-central/firefox_ui_tests/resources

vs.

https://dxr.mozilla.org/mozilla-central/source/testing/firefox-ui/tests/firefox_ui_tests/resources

Wow, the complete images sub folder is missing!
Keywords: regression, regressionwindow-wanted
Ok, so I will include the missing images in my next mirror as covered on bug 1237735.
Depends on: 1237735

Comment 5

2 years ago
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-central: 5

Platform breakdown:
* osx-10-9: 1
* osx-10-6: 1
* osx-10-11: 1
* osx-10-10: 1
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1237608&startday=2016-01-04&endday=2016-01-10&tree=all
This should be fixed now.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.