Closed Bug 1237632 Opened 5 years ago Closed 5 years ago

Enable support for environment/profile/creationDate on Android

Categories

(Toolkit :: Telemetry, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla46
Tracking Status
firefox45 --- fixed
firefox46 --- fixed

People

(Reporter: mfinkle, Assigned: mfinkle)

References

Details

Attachments

(1 file)

Android does ship ProfileAge.jsm and does create a times.json file in the profile. We can easily enable sending the profile.creationDate in telemetry. This is a MUST for using telemetry to create retention/churn data.

Try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=0e8209d311af
Attachment #8705157 - Flags: review?(gfritzsche)
I tested the Try build by installing it over an existing Nightly. The profile.creationDate was correctly displayed in about:telemetry "Environment" section
Attachment #8705157 - Flags: review?(gfritzsche) → review+
https://hg.mozilla.org/mozilla-central/rev/ac1f7dba2219
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
Comment on attachment 8705157 [details] [diff] [review]
use-env-profile-android v0.1

Approval Request Comment
[Feature/regressing bug #]: Old issue
[User impact if declined]: Blocks us from doing any form of churn/retention analysis
[Describe test coverage new/current, TreeHerder]: Landed on Nightly
[Risks and why]: Low. No reason this is different than desktop, it's a very specific code change, and it has tests.
[String/UUID change made/needed]: None
Attachment #8705157 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1136136
Depends on: 1238046
Assignee: nobody → mark.finkle
Comment on attachment 8705157 [details] [diff] [review]
use-env-profile-android v0.1

Should be safe and will be helpful. taking it.
Attachment #8705157 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.