Document IMAP IDLE setting which bug 449021 moved to main account settings screen

RESOLVED FIXED in seamonkey2.43

Status

SeaMonkey
Help Documentation
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rsx11m, Assigned: rsx11m)

Tracking

unspecified
seamonkey2.43

SeaMonkey Tracking Flags

(seamonkey2.41 unaffected, seamonkey2.42 fixed, seamonkey2.43 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

2 years ago
+++ This bug was initially created as a clone of Bug #449021 +++

comm-central changeset 417f2aaf2ed8 moved useIdle.label "Use IDLE command if the server supports it" from am-server-advanced.dtd to am-server-top.dtd and changed it to useIdleNotifications.label "Allow immediate server notifications when new messages arrive" in the process. This needs to be described in the "IMAP Server Settings" section (where the "Advanced" subsection in fact doesn't appear to contain any description for IDLE at all).

Details of the IMAP IDLE capability (to a reasonable extent) and its interaction with the settings for the client polling the server for new mail should be explained in this section.
(Assignee)

Updated

2 years ago
status-seamonkey2.41: --- → unaffected
status-seamonkey2.42: --- → affected
(Assignee)

Comment 1

2 years ago
Created attachment 8706017 [details] [diff] [review]
Proposed patch (A)

This adds an explanation for the new checkbox in the main IMAP server settings panel, referring to its dependency on the server supporting the IMAP capability and its interaction with the other checkboxes.

There was nothing to remove in the Advanced IMAP Server Settings section, but as a drive-by fix, I've added a list item for the number of cached connections.
Attachment #8706017 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 2

2 years ago
Created attachment 8706018 [details] [diff] [review]
Proposed patch (B)

Alternative wording, more explicit on the difference between this checkbox and the other two options.
Attachment #8706018 - Flags: review?(iann_bugzilla)

Comment 3

2 years ago
Comment on attachment 8706018 [details] [diff] [review]
Proposed patch (B)

>+++ b/suite/locales/en-US/chrome/common/help/mailnews_account_settings.xhtml
>+  <li><strong>Allow immediate server notifications when new messages
>+    arrive</strong>: Choose this setting if the server supports IMAP&apos;s
>+    <q>IDLE</q> capability to immediately notify &brandShortName; when new
>+    mail arrives, rather than or in addition to polling the server at startup
>+    and/or regular intervals. This option does not have any effect for servers
>+    which don&apos;t support this capability.</li>
Sorry, this sounds a bit too wordy/complex.
Attachment #8706018 - Flags: review?(iann_bugzilla) → review-

Comment 4

2 years ago
Comment on attachment 8706017 [details] [diff] [review]
Proposed patch (A)

>+++ b/suite/locales/en-US/chrome/common/help/mailnews_account_settings.xhtml

>+  <li><strong>Allow immediate server notifications when new messages
>+    arrive</strong>: Choose this setting if the server supports IMAP&apos;s
>+    <q>IDLE</q> capability to immediately notify &brandShortName; when new
>+    mail arrives. This option does not have any effect for servers which
>+    don&apos;t support this capability. It can be used in addition to any of
>+    the other options to check for mail.</li>
The last sentence could be something similar to:
It can be used in addition to, or instead of, any of the other options to check for mail.

I think the other options are listed close enough to not need mentioning them again.

r=me with that addressed.
Attachment #8706017 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 5

2 years ago
Created attachment 8708850 [details] [diff] [review]
Patch for checkin (v2)

Patch from attachment 8706017 [details] [diff] [review] (A) with "or instead of" additions as suggested.

[Approval Request Comment]
Regression caused by (bug #): bug 449021
User impact if declined: undocumented feature
Testing completed (on m-c, etc.): applies and shows up in Help window
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: l10n change in Help content only
Attachment #8706017 - Attachment is obsolete: true
Attachment #8706018 - Attachment is obsolete: true
Attachment #8708850 - Flags: review+
Attachment #8708850 - Flags: approval-comm-aurora?
(Assignee)

Comment 6

2 years ago
Push for comm-central, please.
Keywords: checkin-needed
Whiteboard: [c-n: comm-central]

Comment 7

2 years ago
c-c landing:
https://hg.mozilla.org/comm-central/rev/5f1dfe01ec67
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.43

Comment 8

2 years ago
Comment on attachment 8708850 [details] [diff] [review]
Patch for checkin (v2)

a=me for comm-aurora
Attachment #8708850 - Flags: approval-comm-aurora? → approval-comm-aurora+

Comment 9

2 years ago
http://hg.mozilla.org/releases/comm-aurora/rev/e943c9d1dffa
status-seamonkey2.42: affected → fixed
status-seamonkey2.43: --- → fixed
Keywords: checkin-needed
Whiteboard: [c-n: comm-central]
You need to log in before you can comment on or make changes to this bug.