in comment http://192.168.0.1/bugzilla/show_bug.cgi?id=115 is convert to messy code

RESOLVED DUPLICATE of bug 726607

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED DUPLICATE of bug 726607
2 years ago
2 years ago

People

(Reporter: shawn.hushaolong, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150603135023

Steps to reproduce:

simply paste a bug link in comment like:
http://192.168.0.1/bugzilla/show_bug.cgi?id=115


Actual results:

save change, in the comment you just submit, it's converted to:

http://192.168.0.1/bugzilla/﷒0﷓


Expected results:

it should be what i paste:

http://192.168.0.1/bugzilla/show_bug.cgi?id=115
oh hey look, it's our friend \U+FDD2 and \U+FDD3. What is the version of bugzilla you are running?
Flags: needinfo?(shawn.hushaolong)
(Reporter)

Comment 2

2 years ago
(In reply to Dylan William Hardison [:dylan] from comment #1)
> oh hey look, it's our friend \U+FDD2 and \U+FDD3. What is the version of
> bugzilla you are running?

hi, i use bugzilla-5.0.1
Flags: needinfo?(shawn.hushaolong)
(Reporter)

Comment 3

2 years ago
I thought i use 5.1, but after double check, it's 5.0.1, has this been fixed in 5.1? If so, could i update to 5.1 without modifying database?

Comment 4

2 years ago
This happens when your hook tries to alter the same text as quoteUrls() itself.
Assignee: general → create-and-change
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Bugzilla-General → Creating/Changing Bugs
Resolution: --- → DUPLICATE
Duplicate of bug: 726607
You need to log in before you can comment on or make changes to this bug.