H.264 cannot work on Red Hat Enterprise Linux 6.5 Firefox 42

RESOLVED INCOMPLETE

Status

()

Core
WebRTC: Audio/Video
RESOLVED INCOMPLETE
3 years ago
a year ago

People

(Reporter: yanfzhen, Unassigned, NeedInfo)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needinfo 2016/07/11 to reporter])

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8705506 [details]
aboutWebrtc_redhat.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151221151411

Steps to reproduce:

1. using  Firefox on redhat to open the link:http://mozilla.github.io/webrtc-landing/pc_test.html 
2. Check on H.264
3. Click start
4. Check whether can see the video succuss


Actual results:

1. Cannot see the video success, you can check from the attachment


Expected results:

1. Can see video success
(Reporter)

Comment 1

3 years ago
Created attachment 8705507 [details]
ice log
(Reporter)

Comment 2

3 years ago
Created attachment 8705511 [details]
1.pic_hd.jpg

Updated

3 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
OpenH264 should work on RHEL, unless the download was blocked.
Component: Audio/Video: Playback → WebRTC: Audio/Video
(Reporter)

Comment 4

2 years ago
What's the progress now?
Most likely they disabled OpenH264 and/or GMP by default in the "official" RH build

Check Tools->AddOns -> Plugins.  I'd bet Open H264 isn't listed as installed.

If it is installed, please re-capture about:webrtc - there's a button to save it.  "Save Page As" doesn't necessarily produce something useful - the copy here doesn't tell me anything useful.
Flags: needinfo?(yanfzhen)
(Reporter)

Comment 6

2 years ago
Created attachment 8714163 [details]
h264addon.png

I check the addons, seems already installed h264 in FF
Flags: needinfo?(yanfzhen)
yanfzhen - please capture another about:webrtc snapshot (preferably using the Save button, not Save Page As).  I need the SDP info.

What version of firefox is it?
Flags: needinfo?(yanfzhen)
(Reporter)

Comment 8

2 years ago
Created attachment 8714194 [details]
aboutWebrtc_new.html

My Firefox version is 44. I saw there is nothing in the sdp, you can check the attachment.
Flags: needinfo?(yanfzhen)
Randell -- Can you look at the data provided?
Flags: needinfo?(rjesup)
Whiteboard: [needinfo 2016/05/12 to Jesup]

Comment 10

2 years ago
There's not a lot to go on here. There's no SDP on about:webrtc, which probably just means that the JS that removes VP8 left no codecs in the m=video section, making it invalid.
Can you try setting NSPR_LOG_MODULES=signaling:5,GMP:5 and NSPR_LOG_FILE=/tmp/nspr.log and try again?  If the plugin is installed, that should work... Unless: while the plugin may get installed, RedHat in their "official" builds might have blocked it (deliberately or accidentally).  Please try using a RH build, and using a Linux build from mozilla.org.

I presume your report was using the default RH build they provide.  Also attach the data from about:support and about:buildconfig

Thanks
Flags: needinfo?(rjesup) → needinfo?(yanfzhen)

Updated

2 years ago
Whiteboard: [needinfo 2016/05/12 to Jesup] → [needinfo 2016/07/11 to reporter]
As we haven't received the requested information this is not actionable. Feel free to re-open this bug when you provide the information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.